Improve company productivity with a Business Account.Sign Up

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 479
  • Last Modified:

Few Exchange services failed to start in SBS 2011

This is using MS SBS 2011 server for various ms product. A MS Exchange was working but suddenly, few services not started after the reboot. Even I set all these services to manual and reboot, and attempt to start them manually, failed. What shall I do? Shall I repair the exchange using sbs DVD or repair disc?
1 Solution
Mahesh SharmaCommented:
Please paste the event log here that you getting while starting service
David AtkinTechnical DirectorCommented:
Which services are failing?  Have you checked the dependancies to make sure those services are started?

Any Exchange updates done recently?
Simon Butler (Sembee)ConsultantCommented:
You can't repair Exchange.
If the server is not on Exchange 2010 SP3 then I would start by installing that. It effectively reinstalls the product and will resolve a lot of issues.

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

MichaelBalackAuthor Commented:
Hi Sembee2,

I am thinking of re-run the exchange setup again, shall I use the repair disc or full disc?
Simon Butler (Sembee)ConsultantCommented:
That isn't going to work.
Exchange cannot be repaired like normal applications.
If you aren't on SP3 then you should update to SP3.
If you are on SP3 then the problem will have to be looked at in other ways.
It isn't possible to reinstall Exchange on top of the existing install.

MichaelBalackAuthor Commented:
Hi Simon,

This is using exchange 2010 sp3, what should I do now? Please advise...
Simon Butler (Sembee)ConsultantCommented:
There should be errors in the event log for when the services fail to start.

I wouldn't reinstall just yet, only because you don't know what caused the problem.  I agree with Sembee2, we should really examine the event log to determine what the issue is that is preventing them from starting.

In addition, do you recall making any changes lately to things like:

- Antivirus software
- Windows updates
- Administrator passwords


Can you double check once whether ipv6 is enabled on the Nic card?

If not enable IPV6 and start the services.

Imran Shariff
MichaelBalackAuthor Commented:
Hi Imran,

The IPv6 was disabled by my team mate, after re-enabled, all the exchange services can be started again.

But there is another problem - Exchange management console can not be opened. It shows the error message when tried to open:

 Initialization failed
 The following error occurred while attempting to connect to the specific exchange server: "mail.companya.local"

The attempt to connect to http://mail.companya.local/powershell using "keberos" authentication failed. Connecting to remote server failed with the following error. The winrm client process the request. It cannot determine the content type from the http response type from the destination computer. the content type is absent or invalid.
MichaelBalackAuthor Commented:
This is how i did:

1. On NIC, enable IPv6
2. Using server manager, add in a feature - winrm
3. Edit a registry key, to priortize ipv4 traffic on ipv6
4. reboot the system

After, exchange services can be started automatically. EMC can be accessed.
MichaelBalackAuthor Commented:
It works
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now