Solved

Exchange 2010 Database wont mount

Posted on 2013-11-22
4
9,942 Views
Last Modified: 2015-04-06
Hi All

I hope you can help.

I have a 3 node setup of Exchange 2010

Prod site = 1 x HUB, 1 x CAS,Mailbox

DR Site = 1 x Hub, CAS, Mailbox

Today my Prod Mailbox server was restarted and afterwards wouldnt mount its one database.  Initially after running ESEUTIL, it had a state of Dirty Shutdown.  I ran through a procedure detailed in msexchangeguru.com which allowed me to check the logs, check the health of the logs and then perform a Soft Recovery, after that point I was able to show a Clean Shutdown, but still wasnt able to Mount the Database.

I then proceeded to move the log files from the Transaction folder in the hope that now having a Clean Shutdown this would resolve the issue, but it hasnt.  here is the current error I am receiving when I right click and try to mount:-

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database 0505228569'.

Mailbox Database 0505228569
Failed
Error:
Database 'Mailbox Database 0505228569' can't be mounted on server 'SERVERNAME' due to a previous error: Failed to determine the mount status of the active database copy. Verify that the underlying cause of the error has been corrected before attempting to mount the database. The error can be ignored and the mount allowed if Mount-Database is reissued with the -Force switch.




--------------------------------------------------------
OK
--------------------------------------------------------

In EMS I get this:-

Couldn't mount the database that you specified. Specified database: Mailbox Database 0505228569; Error code: An Active
Manager operation failed. Error An Active Manager operation encountered an error. To perform this operation, the server
 must be a member of a database availability group, and the database availability group must have quorum. Error: Automo
unt consensus not reached..

I had a DAG previously, but now it only contains the CAS, Mailbox server on the Prod site so in effect its a single node DAG.  Running test-replication shows:-

Server          Check                      Result     Error
------          -----                      ------     -----
SERVERNAME         ClusterService             Passed
SERVERNAME         ReplayService              Passed
SERVERNAME         ActiveManager              *FAILED*   Active Manager is in an unknown state on server 'SERVERNAME'. Bas...
SERVERNAME         TasksRpcListener           Passed
SERVERNAME         TcpListener                Passed
SERVERNAME         DagMembersUp               Passed

Can anyone shed some light on what I can try please?

Thanks

Fingwong
0
Comment
Question by:fingwong
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 37

Accepted Solution

by:
Mahesh earned 500 total points
ID: 39670507
Please try below since you have single node DAG, I suspect it is quoram error
 Ran the following commands with the EMS:
 
 Stop-Service ClusSvc
 net start clussvc /forcequorum
 start-databaseavailibilitygroup -identity DAG
 get-databaseavailabilitygroup -identity DAG -status | fl name,primaryActiveManager
 mount-database DB1 -force


replace DAG name and DB name as appropriate
Mahesh
0
 

Author Closing Comment

by:fingwong
ID: 39670682
Mahesh

What an absolute legend.

Worked exactly as you said.

Thanks

Nick
0
 
LVL 37

Expert Comment

by:Mahesh
ID: 39671335
The likely cause of this issue is you lost primary active manager (PAM) on production Exchaneg server after reboot, and thats why lose the DAG Quorum as well.
Since DAG don't have enough voters, it failed to mount database..
Thats why we have imported quorum forcefully to mount database..
http://technet.microsoft.com/en-us/library/dd776123(v=exchg.141).aspx
http://technet.microsoft.com/en-us/library/dd776123(v=exchg.141).aspx
http://www.telnetport25.com/2011/12/its-a-majority-thing-dag-voting-explained-a-bit/

You said that previously you had DAG (may be two node) and now you have only one server in DAG....
Below things are not clear from above statement..
What about DR mailbox server ? if it is part of DAG then
What about Witness Server ? then you must have witness server as well....
If you could explain how many databases and databases copy you have and on which servers , then only we can identify root cause..

Mahesh
0
 

Expert Comment

by:vivek singh
ID: 40709575
Thanks Mahesh ...for finding root cause about the issue
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article demonstrates probably the easiest way to configure domain-wide tier isolation within Active Directory. If you do not know tier isolation read https://technet.microsoft.com/en-us/windows-server-docs/security/securing-privileged-access/s…
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question