Solved

Terminal Server through HyperV

Posted on 2013-11-23
5
375 Views
Last Modified: 2013-11-30
Hello Experts.  I have the following configuration.  

1) A Host Server running Server 2008 R2 with the Hyper V role installed
2)A brand new SBS 2011 Hyper V virtual machine installation which will run exchange and has the Remote Desktop Services installed and the license Server is activated for Remote desktop
3)A second Hyper V virtual machine which will run a terminal server for remote clients to connect to

My question, I am having trouble figuring out how to allow a remote users to connect to the Server in step 3.  Any quick advice?
0
Comment
Question by:Lounger-Master
  • 3
5 Comments
 
LVL 20

Assisted Solution

by:Svet Paperov
Svet Paperov earned 400 total points
ID: 39671816
As you will do it for any Terminal Server, no matter if it's running as a Hyper-V virtual machine or on a physical host. From end-client point of view there is no difference.

That means: installing the required service roles, licenses, certificates for Web Access, and opening the required port on the perimeter firewall if you want access from Internet.
0
 

Author Comment

by:Lounger-Master
ID: 39672152
I have done so and when I try to connect to the Terminal Server using the RD Gateway to authenticate I get an error saying "Your computer cant connect to the remote computer because the remote desktop gateway server address requested and the certificate subject name do not match.  What did I miss?  I did setup a purchased and valid SSL certificate and it is not giving me an error when I access Outlook Web Access.  Thoughts?
0
 
LVL 57

Expert Comment

by:Cliff Galiher
ID: 39672167
If you are trying to do this via RDGateway on he SBS server, the easiest route is to use the SBS cert wizard to generate a CSR and then rekey. Then use the SBS wizard again to install the cert. Setting a certificate in IIS is independent from RDGateway, so using exchange walkthroughs on the web will cause the mismatch error you describe. With SBS, it is always best to stick to the wizards.
0
 

Accepted Solution

by:
Lounger-Master earned 0 total points
ID: 39672205
That's how I had done it.  What happened was I was doing testing before the A record was established and used an IP address in the RD Gateway field on the Remote Desktop client.  I changed it to the remote.domain.com domain and now that it matches the SSL certificate and it logs in without issues.  Thank You for your input.
0
 

Author Closing Comment

by:Lounger-Master
ID: 39686650
Multiple answers apply
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Desktop Shadowing often has a lot of benefits. When helping end users determine problems, it is much easier to see what is going on, what is being slecected and what is being clicked on. While the industry has many products to help with this,…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now