Solved

SSL - DNS - i switched to a dedicated IP

Posted on 2013-11-24
10
500 Views
Last Modified: 2013-11-24
Hi i have an ecommerce website set up on a dedicated server that as more than 10 domains set up.

The dedi server runs plesk 11. centOS

its my first time installing a SSL cert so i just need some reassurance that what i have done is correct.

i read that i must have a dedicated ip for the ecommerce site so the SSL will work. i have added another IP to the dedi box and logged in to plesk to assign the new ip to the ecommerce site.

As soon as i changed the ip from the shared over to the new ip i got a message saying the ip doesn't resolve for the domain and i should fix the dns settings.

i guessed that this was just a warning as the dns had not transferred over to the new ip yet? so should just wait and the problem should be ok.

My other concern is: do i need to reupload the site to the new ip address? or will plesk do this automatically?
0
Comment
Question by:helpchrisplz
  • 6
  • 4
10 Comments
 
LVL 1

Author Comment

by:helpchrisplz
ID: 39672766
since i changed the ip over to the new dedicated one the site is just showing the default blue plesk page that you get when you first set up a domain: http://www.jrfox.co.uk/

will this just fix its self with time?

The site did show the working ecommerce site before doing the ip change.
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39672791
http://www.jrfox.co.uk/ seems to work fine on my end.  Did you install the cert?  I get errors with https.
0
 
LVL 1

Author Comment

by:helpchrisplz
ID: 39672801
it says its Awaiting Verification.

will the site automatically just go to the padlock once i install fully?

or do i need to redirect to the secure version some how?
0
Resolve Critical IT Incidents Fast

If your data, services or processes become compromised, your organization can suffer damage in just minutes and how fast you communicate during a major IT incident is everything. Learn how to immediately identify incidents & best practices to resolve them quickly and effectively.

 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39672817
I have plesk on a windows server.    Going from memory:

1) Generate the CSR in Plesk

2) Paste the CSR to where I am buying the Cert

3) The cert issuer will require some type of verification.  This could be an email to the domain, uploading a special html file or placing some meta data in the head tag.

4) Once verified, the issuer will email you the certificate or they will show it to you on their site.

5) Depending on the issuer, you may have to install an intermediate cert.

6) In Plesk, go back to the ssl area and update the cert and if required the intermediate cert.

7) You will have to delete the old cert (click the check box and choose remove)

8) Make the current cert active.

If you get stuck on any of these steps, let us know.
0
 
LVL 1

Author Comment

by:helpchrisplz
ID: 39672838
i verified by using a email on the domain.

i now have the Certificate and i have added it to the domain but i can see that the Certificate CA box is empty and the sites still dont work on https

is it normal not to get a CA?
0
 
LVL 52

Accepted Solution

by:
Scott Fell,  EE MVE earned 500 total points
ID: 39672853
It depends on the issuer.  If they don't require one, then you don't need it.  Once you click the "send" button, both box's will be empty and you will only see the certificate info below.

Your last step is to go to websites and domains. Click on the domain name and then check the box, "Enable SSL support".  This step is not very intuitive.
0
 
LVL 1

Author Comment

by:helpchrisplz
ID: 39672861
yes. i found it in the hosting settings part on plesk just had to select the cert and make sure ssl was switched on.

the site now works! yey.

it doesn't automatically switch to https though do you know of a way to force it to load of the https?
0
 
LVL 1

Author Comment

by:helpchrisplz
ID: 39672873
might have to update the site url in the database i think
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 39672883
You should be able to do this in php or your htaccess file

RewriteCond %{HTTPS} !=on
RewriteRule ^/(.*) https://%{SERVER_NAME}/$1 [R,L]
0
 
LVL 1

Author Closing Comment

by:helpchrisplz
ID: 39672915
thanks

i found that the only way i could force https was to change the unsecure base url to be the secure one in the database.

UPDATE `core_config_data` SET `value`='https://www.example.com' WHERE `path`='web/unsecure/base_url';
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Periodically we have to update or add SSL certificates for customers. Depending upon your hosting plan you may be responsible for the installation and/or key generation. In the wake of Heartbleed many sites were forced to re-key. We will concen…
SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question