Solved

Users can create files and folders in home drive but can't change them

Posted on 2013-11-25
5
317 Views
Last Modified: 2013-11-30
I just did a file server migration frmo an old Windows 2003 server to a new 2008 server.  I migrated all our users home directories over with no issues...Or so I thought.  Users can access their directories, can create files and folders within their directories, but cannot edit any MS Office files after they've been created.  If I try and edit one, even as an Administrator, I get an "Access Denied" error.  I can create and edit text files all day long in the same location.  Help!!!
0
Comment
Question by:tenover
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 15

Expert Comment

by:Giovanni Heward
ID: 39675185
Once you've logged in as the domain admin, whats your results when running the following commands, from an elevated privileged command prompt?

takeown /F x:\directory /R

Open in new window


cacls x:\directory

Open in new window

0
 
LVL 37

Expert Comment

by:Mahesh
ID: 39675259
Try below
Logon to file server with user having administrative rights.

1st of all check what share permissions for authenticated users on root share folder under which home directories residing
Ensure that Change - share permission to "Authenticated Users" group.If not then please provide the same.

Permissions may not be applied from parent folder to subfolders and files, so please check the permission of the file instead of the parent folder and see if user has Full Control permission on that file.
if not, then provide user (owner of home directory) with required NTFS permissions (Modify) on it's respective  home directory and click apply.
Then from advanced NTFS security permissions window, select "replace all child object permissions with inheritable permissions from this object" checkbox and apply.
if you faced any access denied error at this stage then
Take ownership of folder through NTFS advanced security permissions with "Replace owners on subcontainers" option selected.
Then once again try step mentioned above in bold and check user is able access files.

Best practises for home directories
http://support.microsoft.com/kb/555046

Mahesh
0
 
LVL 15

Expert Comment

by:Giovanni Heward
ID: 39675323
0
 

Accepted Solution

by:
tenover earned 0 total points
ID: 39675337
Problem resolved.  Turns out it was the File Resource Manager blocking .tmp files on that directory, hence you could modify .txt files just fine but not Office docs.
0
 

Author Closing Comment

by:tenover
ID: 39686666
Fixed myself.  Also, this question accidentally got posted twice.
0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question