Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 213
  • Last Modified:

User access issue

The user complained that he was unable to access 2 out of 20 databases on one of the servers. I checked the user permissions and found that the only difference between the user permissions on those two databases and the rest of them was that the default schema listed was DOMAIN\user1 instead of dbo. Another thing was that in Owned Schemas section the schema DOMAIN\user1 was selected for those two databases in question, all other databases do not even have DOMAIN\user1 listed under schemas.
I did change the default schema to dbo, but I do not know how to remove DOMAIN\user1 schema from the list or uncheck it

Can someone help me fix this issue?
0
YZlat
Asked:
YZlat
1 Solution
 
Carl TawnSystems and Integration DeveloperCommented:
You should just be able to execute the following command from SSMS:
DROP SCHEMA 'DOMAIN\user1'

Open in new window

Although it will error if the schema owns any objects - in which case you will have to change the owner of all of the objects and then drop again.

It would be wise to backup your database before doing this as well :)
0
 
YZlatAuthor Commented:
I dropped the schema and reset the default user schema to dbo but user sitll reports he is unable to access those databases
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now