Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 767
  • Last Modified:

troubleshooting help for an IP address conflict that took down network for a bit

Greetings,

we had an IP address conflict take down the network earlier. It has since been resolved and the MAC address pointed to an AMP Wireless WAP. The WAP is connected to an HP Procurve 2810 (I think - it's downstairs). We had this issue some time back as well and traced it to a TrendNet WAP, which happened to be connected to the same switch. Both WAPs are (were) configured with a static IP and DHCP was disabled on both (verified by logging in). Disconnecting the WAP solved it.

It happened after I moved the WAP from one location in the office to another. Since I moved it, I had to connect to a different port but the same switch. Once I plugged it in and connected it to the port, almost everyone received an IP conflict message and could not access network or internet resources.

All that said, could it be the switch? The WAP had been plugged in for several months, and had been moved once before just last week, without issue.

Thanks for any insight. This was a pain and would like to avoid it happening again.
0
king daddy
Asked:
king daddy
  • 12
  • 7
2 Solutions
 
duttcomCommented:
Is there a DCHP reservation for that WAP on your DCHP server? If DCHP does not have a reservation for that WAP on that specific IP address (you will also need its MAC address to create the reservation) then it may allocate the WAP's IP address to another client while the WAP is not on the network, causing a clash when it comes up again on the same IP.
0
 
king daddyAuthor Commented:
thanks duttcom. It does not have a reservation. I have not created a reservation for any of the three WAPs in the network. I did not think it was necessary since the static IP of the WAP was not in the DHCP scope. I have only created a reservation for two copiers on the network that have static IPs within the scope. Also, the WAP was only powered off for a minute while I walked from one side of the floor to another. Would it be possible for the DHCP server to hand out a static IP outside of the scope to another device on the network in that short amount of time, causing the conflict? I show a TCPIP error event ID 4199

The system detected an address conflict for IP address 192.168.45.86 with the system having hardware network address WAPMACADDRESS. Network operations on this system may be disrupted as a result.

To note, this affected 60+ workstations (DHCP), the DHCP server (static), and a handful of servers (some servers were not affected but they are all static).
0
 
duttcomCommented:
Does the DNS show anything for that IP address? Also, with the WAP turned off, if you run arp -a in a command prompt, does the IP address show up in the arp table with a  recognisable MAC address?
0
NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

 
duttcomCommented:
Another thought - can you log in to the admin for the ProCurve switch and see if there is an option for rebuilding or resetting the arp cache on the switch?
0
 
king daddyAuthor Commented:
I will check out your suggestions as soon as I can and post back. Thanks again for your help.
0
 
king daddyAuthor Commented:
nothing in DNS. I did find the MAC address in the arp table from my workstation. The IP was 192.168.45.144. This IP is within the DHCP scope and not the static configured IP of the WAP. will post back regarding the ProCurve.
0
 
duttcomCommented:
Interesting. Was there a MAC address listed for 192.168.45.86?
0
 
king daddyAuthor Commented:
I'll have to check. I wanted to note that .86 is the static IP of a server that had the IP address conflict. I chose it at random for this posting. Each machine that was affected by an IP address conflict had its own IP in the tcpip error.

Thx again
0
 
duttcomCommented:
Ah okay, that makes a bit more sense, but doesn't make it any clearer unfortunately.

I'll have a think about where else you might find the offending IP menace.

Did you try the WAP in any other switch, or rebooting the switch?
0
 
king daddyAuthor Commented:
I didn't reboot switch nor did I plug the WAP into another switch (didn't feel like dealing with it again today, if it reoccurred).

I'm a bit confused. I assumed the WAP was giving out IP addresses which conflicted with the DHCP server and static addresses. This exact same thing happened over the past summer with a trend net WAP that was connected to the same switch. It worked out when I disconnected it from the switch. I've since reset the WAP and am using it on another switch on another floor without issue.
0
 
Craig BeckCommented:
Does the AP run ProxyARP?
Is the AP configured as a repeater or WDS bridge?
0
 
king daddyAuthor Commented:
craigbeck - it does not run ProxyARP as far as I know. The previous WAP (trend net) was set up as a repeater but the AMP Wireless WAP in this post is neither (I just gave it a static IP, set up the SSID, disabled DHCP, and then plugged it in). Thanks
0
 
king daddyAuthor Commented:
went to .144 in a web browser and it was the Amped WAP in question. The static IP shows .93 but it responded to .144. DHCP is set to client, so I guess that's how it picked up .144.

 Just realized one of the trendnet WAPs is also .93 static and I can get to its interface in a web browser by going to .93.

still confused about the IP conflicts on several machines showing the IP of the affected machine and the MAC of the Amped WAP.

thanks again for the help with this
0
 
king daddyAuthor Commented:
I had disconnected the Ethernet cable from the Amped WAP yesterday but left it powered on. I thought it was impossible for me to connect to it but I did on .144. After I unplugged the Ethernet cable yesterday things calmed down. I am able to get an IP address on my iPhone from the WAP and also get online (turned off cellular to verify). The DNS setting shows .144 as the DNS server. Nonetheless, I can get online successfully. I'm thinking there is an issue when it's hard wired but no issue when it's not connected to the switch. Since I can get online, it must be either in repeater or some other mode that somehow connects it to the network which allows successful connections to the internet. I need to figure out the IP address of this thing since it's getting .144 from dhcp but configured for a static of .93 which conflicts with another WAP.
0
 
king daddyAuthor Commented:
just noticed this on the WAP web banner

High Power Wireless-N 600mW Gigabit Dual Band Range Extender / Repeater

here are the connections

5.0GHz Network IP Settings
IP Address:
192.168.45.144
Subnet Mask:
255.255.255.0
Default Gateway:
192.168.45.1


2.4GHz Home Network Wireless Settings
SSID:
bukfs
Encryption:
WEP 64bits
BSSID:
00:15:c7:80:f7:e0
Connection State:
Connected
Signal Strength:
41%


2.4GHz Extended Network Wireless Settings
Band:
2.4 GHz (G+N)
SSID:
BUKFS2
Channel Number:
8
Encryption:
WEP 64bits
BSSID:
f8:7b:8c:10:25:c1
Associated Clients:
2


2.4GHz Network IP Settings
IP Address:
192.168.45.144
Subnet Mask:
255.255.255.0
Default Gateway:
192.168.45.1

There is an IP settings config page which shows the static .93 grayed out, as well as the subnet mask and the gateway, with DHCP set to client. I added a reservation for .144 on the DHCP server.
0
 
duttcomCommented:
So .144 is the IP address for the wireless interfaces (2.4 and 5GHz) and .93 is the static IP address of the Ethernet connection. That would explain why you can connect to wirelessly it via .144 when it isn't connected to the network. That would also explain why it would cause a problem when connected via ethernet because there is already another WAP on .93

Can you change the static IP of the Amped WAP from .93 to something else that you know is available or is that option grayed out with no hope of changing it?
0
 
king daddyAuthor Commented:
Since it's working I'm going to leave it at .144. I created a reservation in dhcp. I'm going to change it (it is possible to do so) to .94 when I can test. I expect it to work but don't want to deal with it right now if not.

Thx for the help
0
 
duttcomCommented:
Any day you don't take down the entire network is a good one. Good luck with it all.
0
 
king daddyAuthor Commented:
HA! Indeed! Thx
0
 
king daddyAuthor Commented:
thx. sorry it took so long to award points. I added a reservation and changed to a static IP and it has been working.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 12
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now