?
Solved

mysql error: Error: 23 - Out of resources when opening file

Posted on 2013-11-25
8
Medium Priority
?
967 Views
Last Modified: 2013-12-17
My server has a site that's getting a lot of traffic lately and I'm seeing some mysql errors coming up in the IP.Board logs.  It says it's an error with mysql not the software.

Anyone know how to fix the error:
Error: 23 - Out of resources when opening file
0
Comment
Question by:Nathan Riley
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 12

Author Comment

by:Nathan Riley
ID: 39676596
I found some people saying to open:
/etc/security/limits.conf

and add:
mysql soft nofile 24000
mysql hard nofile 32000

Any issues with doing this?
0
 
LVL 36

Accepted Solution

by:
Loganathan Natarajan earned 668 total points
ID: 39676710
Also do this,

Increase the open file limit in the "/etc/mysql/my.cnf"

open_file_limit=3072

Open in new window


Stop / restart the mysql after that.

ref. http://dev.mysql.com/doc/refman/5.0/en/limits-windows.html
0
 
LVL 12

Author Comment

by:Nathan Riley
ID: 39676719
Your link is for windows I believe. My server is running Linux.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 12

Author Comment

by:Nathan Riley
ID: 39698233
No one?
0
 
LVL 20

Assisted Solution

by:Daniel McAllister
Daniel McAllister earned 668 total points
ID: 39724030
Gallitin:

While the link provided by logudotcom may have been for Windows, the entry above it (where he suggests open_file_limit=3072 in /etc/mysql/my.cnf) is actually Linux -- albeit, on some Linux systems, my.cnf is in /etc, not in /etc/mysql.

That being said, in addition to there being an open file limit being exceeded, you may also be overstepping your memory bounds... but I would try the open files setting first.

Dan
IT4SOHO
0
 
LVL 35

Assisted Solution

by:Seth Simmons
Seth Simmons earned 664 total points
ID: 39724034
your first comment about modifying limits.conf should fix your issue
try it and see how that works
no harm in making the change
0

Featured Post

CHALLENGE LAB: Troubleshooting Connectivity Issues

Goal: Fix the connectivity issue in the lab's AWS environment so that you can SSH into the provided EC2 instance.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to security, close monitoring is a must. According to WhiteHat Security annual report, a substantial number of all web applications are vulnerable always. Monitis offers a new product - fully-featured Website security monitoring and pr…
In this blog post, we’ll look at how using thread_statistics can cause high memory usage.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question