Kaspersky KIS 2013 won't update past 15%

I'm trying to update KIS 2013, but it won't get past 15%. I have tried doing the online update as well as downloading the update without internet connections & installing from a folder. Same results both times.

I also have uninstalled & reinstalled it. I'm doing this on a Windows 8 laptop.

I know there has to be others with this problem because I have read the Kaspersky forum & there are many with the problem, but almost none with a solution.

Thanks for any help!!
LVL 1
BlinkrAsked:
Who is Participating?
 
Thomas GrassiSystems AdministratorCommented:
When you uninstall Kaspersky sometimes it does not remove the product entirely

Have you used the Kaspersky removal tool?

http://www.kaspersky.com/antivirus-removal-tool?form=1

This error is database corruption Kaspersky has had this issue for a long time.

Give the removal tool a try

Make sure you restart computer prior to re installing.
0
 
aadihCommented:
You could also use Revo Uninstaller to uninstall. Perform an advanced scan.
0
 
BlinkrAuthor Commented:
Thanks for the quick answers. I tried both suggestions & installed KIS back & still have the same problem.

Any other suggestions??
0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
aadihCommented:
When did the problem start? Very recent? You may try system restore (from safe mode with command prompt and type rstrui.exe).
0
 
Thomas GrassiSystems AdministratorCommented:
Do you have any other anti virus program installed?

sometimes when you download an app from the web they install other programs.

Double check

The KIS remover did not help?
0
 
BlinkrAuthor Commented:
Thanks fro the help!! Neither solution worked but they should have. I still haven't found the answer, so if anyone does find the answer please post here!!

I ended up just fully removing KIS 2013 & installing KIS 2014. Everything worked fine after that. So I'm guessing that it is a 2013 problem. They have offered some patches, but you can only get thru the update. They really need to offer some utilities for problems like these similar to there uninstall little utility.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.