Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook 2010 - Automatic Reply Cannot Be Displayed Because Server is Unavailable

Posted on 2013-11-26
7
Medium Priority
?
2,443 Views
Last Modified: 2014-04-23
Most internal users are experiencing the issue of not being able to set Out Of Office replies via Outlook, going against Exchange 2010.  All users are internal to the network and setting does work from OWA.  The error is the same on all workstations:

Your automatic reply settings cannot be displayed because the server is currently unavailable.  Try again later.

I have verified Outlook Connectivity via right-click Connection Status and have also tested the autoconfiguration without error ( right-click Outlook, Test Email Autoconfiguration ).  The Log tab shows Autodiscover is found and succeeded.  In the results tab, I can take the  URL for OOF and successfully browse to it.

I have the latest Office service pack and all services are running on the server.

I have browsed dozens of articles and am unable to find the answer.  Most indicate it is an autodiscover issue, but autodiscovery is correctly functioning.
0
Comment
Question by:OllarConsulting
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39678218
It rarely is anything other than Autodiscover - so that is the first place you need to check.
Look at the results. Verify that all of the URLs being returned are
a. Correct, and resolve to the Exchange server via its INTERNAL IP address.
b. Are on the SSL certificate
c. The SSL certificate is trusted.

Exactly what version of Exchange 2010 are you using?

Simon.
0
 
LVL 5

Expert Comment

by:nashim khan
ID: 39678517
Hi,

Please run the below command and see, and reply if not fixed.

First run the "Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl"
 
and then run

"Set-webservicesvirtualdirectory" with the correct URL. Also check the certificate, and verified the URL resolving the correct place or not which is configured for Autodiscover in certificate FQDN.
0
 

Author Comment

by:OllarConsulting
ID: 39678561
The Get-webservicesvirtualdirectory returns the following:

Identity    : FS1\EWS (Default Web Site)
InternalUrl : https://mail.myDomain.com/EWS/Exchange.asmx
ExternalUrl : https://mail.myDomain.com/EWS/Exchange.asmx

These are valid URLs and result in XML when navigating via a web browser.

Our SSL Cert if a purchased cert, covers mail.myDomain.com, and mail.myDomain.com resolves to the server's internal IP when connected to our internal network.

We are running Exchange 2010, version 14.1 ( Build 218.15 )
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 5

Expert Comment

by:nashim khan
ID: 39678569
Please check the below steps.

======================
 1. On Exchange CAS server, open IIS console,
 2. Go to default web site, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
 3. Click Autodiscover, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
 4. Click EWS, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
 5. Click OAB, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
 6. Please run IISRESET command to load the changes.
 7. On client computer, open IE, try to visit https://mail.domain.com, confirm it is successful. Try to visit https://mail.domian.com /autodiscover/autodiscover.xml, type credential if it prompts, make sure you can access the page.
 

Please collect these logs for further research if the issue is not gone. Thanks.


FYI below is the link.

http://social.technet.microsoft.com/Forums/office/en-US/74f0e3f8-5d50-4c73-9529-8ec70ae6bee3/outlook-error-your-automatic-reply-settings-cannot-be-displayed-because-the-server-is-currently?forum=outlook
0
 

Author Comment

by:OllarConsulting
ID: 39678589
Client Certificates was already set to "ignore" for all of the above and I can successfully navigate to both URLs....
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 39678673
"We are running Exchange 2010, version 14.1 ( Build 218.15 ) "

Lets stop right there.

That is Exchange 2010 SP1, and is no longer supported.

You should upgrade to Exchange 2010 SP3 with at least rollup 2 to begin with. I find that installing the service packs will resolve a lot of issues because it effectively reinstalls the product.

Simon.
0
 

Author Comment

by:OllarConsulting
ID: 39678856
I will give that a try and report back...
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question