?
Solved

Can't connect to Exchange 2013 powershell

Posted on 2013-11-26
7
Medium Priority
?
6,323 Views
Last Modified: 2013-12-03
I've tried to connect to PowerShell however I get following errors. There is a URL rewrite redirection but not for the Powershell sub and even if disabled, still doesn't work. SSL certificate is issued for both URLs and ECP and other virtual sub directories are working fine.

VERBOSE: Connecting to exchange.company.uni.edu.au.
New-PSSession : [exchange.company.uni.edu.au] The WinRM service cannot process the request because the request needs
to be sent to a different machine. Use the redirect information to send the request to a new machine.  Redirect
location reported: https://exchange.company.uni.edu.au/powershell?serializationLevel=Full;ExchClientVer=15.0.516.32;c
lientApplication=ManagementShell;TargetServer=;PSVersion=4.0&sessionID=Version_15.0_(Build_515.32)=rJqNiZqNgbqnvLe+sbi6
0Z6b0YqOipGWkJHRio7RmpuK0Z6Kgc7Gy87GxsnPzMmBzc3Qzs7Qzc/OzN/LxczIxc/L376y . To automatically connect to the redirected
URI, verify the "MaximumConnectionRedirectionCount" property of the session preference variable "PSSessionOption", and
use the "AllowRedirection" parameter on the cmdlet.
At line:1 char:1
+ New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
   gTransportRedirectException
    + FullyQualifiedErrorId : RedirectInformationRequired,PSSessionOpenFailed
Failed to connect to an Exchange server in the current site.
Enter the server FQDN where you want to connect.: exchange.company.com.au
VERBOSE: Connecting to exchange.company.com.au.
New-PSSession : [exchange.company.com.au] Connecting to remote server exchange.company.com.au failed with the following error
message : WinRM cannot process the request. The following error occurred while using Kerberos authentication: Cannot
find the computer exchange.company.com.au. Verify that the computer exists on the network and that the name provided is
spelled correctly. For more information, see the about_Remote_Troubleshooting Help topic.
At line:1 char:1
+ New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
   gTransportException
    + FullyQualifiedErrorId : NetworkPathNotFound,PSSessionOpenFailed
0
Comment
Question by:JurajUQU
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 900 total points
ID: 39679282
I would start by removing all redirection across the entire server to begin with, because something with that configuration is getting in the way.

What is the purpose of the redirection/rewrite?

Simon.
0
 
LVL 5

Author Comment

by:JurajUQU
ID: 39679289
I've tried that - didn't help. Redirection is only http to https
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39684018
Did you run iisreset after removing the redirection?
Do you have a proxy on the network?

Simon.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 5

Assisted Solution

by:JurajUQU
JurajUQU earned 0 total points
ID: 39684310
Hi Simon,

no but I was able to resolve it. I unticked all of the redirection (which didn't help) so then I deleted the rule from URL rewrite, restarted the IIS, and it worked. Then I re-enabled it as it was before and it still is working.

Not sure what has changed but assuming that webconfig file was updated incorrectly or something so removing the rule solved it for me.
0
 
LVL 5

Author Comment

by:JurajUQU
ID: 39684319
I've requested that this question be closed as follows:

Accepted answer: 0 points for JurajUQU's comment #a39684310

for the following reason:

I was able to resolve it myself.
0
 
LVL 5

Author Comment

by:JurajUQU
ID: 39684320
Simon has mentioned it before which I realised after so I'd like to award him some points.
0
 
LVL 5

Author Closing Comment

by:JurajUQU
ID: 39692032
Thanks
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question