Exchange 2013 Autodiscover Problem

Hello,

I have an Exchange 2013 with latest CU2 update installed. Everything is working fine except autodiscover. Im testing the autodiscover through Microsoft remote connectivity analyzer and it passes all tests except the last that says " 

Testing HTTP Authentication Methods for URL https://mail.interworkscloud.net/rpc/rpcproxy.dll?7cf2d19c-0cea-4271-8601-679c0a4790ab@interworkscloud.net:6002.
       The HTTP authentication test failed.
       
      Additional Details
       
A Web exception occurred because an HTTP 501 - NotImplemented response was received from Unknown.
Headers received:
Pragma: no-cache
Content-Length: 29
Cache-Control: no-cache,no-store
Content-Type: text/html
Expires: now
Elapsed Time: 610 ms.


Any ideas ?

Thanks
Anestis PsomasSystem and Network AdministratorAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
I did use Zen, I don't any longer as I have Kemp and JetNexus on my network (NFR copies).
What are you load balancing exactly? MAPI, HTTPS? You have to be careful with the host names, otherwise you could be directing traffic back to the load balancer.

Simon.
0
 
Simon Butler (Sembee)ConsultantCommented:
That is an Outlook Anywhere error.
When you bound the SSL certificate, did you do it to the correct web site? If you use the Exchange Admin Center then it was done for you - only problem if you used IIS.

Any other errors in the event viewer at all?

Have you changed anything away from the default configuration, particularly of the underlying OS?

Simon.
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
Hello Simon ,


The certificate was installed from inside the ECP .

The only thing i change from the default configuration after i found out about the error ,  is the OutlookProviders which i add my  wildcard certificate in the principalname  and also i change the outlook anywhere authentication for external access to negotiate .

In the OS i only update the system. In event viewer i see a lot of warning and errors. I search something more specific and i will post it here.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
Im unable to find anything in the Event viewer to have some kind of relation with the Autodiscovery process. Is there maybe another way to test it through IIS ? I see in my CAS server in IIS a virtual directory with name RPC .

Thanks
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
Hello ,

I manage to pass the error . In my Load Balancer in HTTP verbs accepted i enable +MS RPC Extensions verbs .

Now the testconnectivity hangs in another part . The error i take is

Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server c738e8d9-40c7-4b18-a128-f1a95f43ae3a@interworkscloud.net.
       The attempt to ping the endpoint failed.
       
      Additional Details
       
An RPC error was thrown by the RPC Runtime process. Error 1818 CallCancelled
Elapsed Time: 33086 ms.


Any ideas about this ?

Thanks
0
 
Simon Butler (Sembee)ConsultantCommented:
Would have helped if you mentioned the use of a wildcard certificate and the load balancer.
The first thing to do when you get problems is to bypass the load balancer. You need to ensure that Exchange is working correctly before you start to put traffic through the load balancer.

Simon.
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
My mistake Simon, i will test the configuration without the LB and i will tell you the results.

Thanks
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
Hello again ,

I try without load balancer and it plays perfect. When i enable the LB then i take the error about the RPC endpoint 6001 which i explain before 2 posts

Thanks
0
 
Simon Butler (Sembee)ConsultantCommented:
If everything works without the load balancer, then the problem is with the load balancer configuration. You may have to go back to the load balancer support to confirm you have the load balancer and Exchange configured as required.

Simon.
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
Thanks a lot Simon , Im searching for a solution right now. Do you have maybe any ideas ? Im using Zen Load Balancer . I remember telling me in another topic that you have use it .

Thanks
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
Hello Simon ,


Right now im load balancing OWA , and of course RPC over HTTPS and port 443 . As we know all traffic goes through port 443. All working perfect except the autodiscovery . What do you mean to be careful with the host names ?


Thanks
0
 
Anestis PsomasSystem and Network AdministratorAuthor Commented:
I download a trial of Kemp LB and it works perfect , so something is wrong with ZenNLB.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.