Solved

Log in to Horde Webmail, but just web page

Posted on 2013-11-26
15
500 Views
Last Modified: 2013-12-20
I log into Horde webmail and i am able to see my e-mails on the laptop. However on a smartphone or ipad, when i log into Horde webmail all i see is a blank page. I need help on this.
0
Comment
Question by:christoforatos1968
  • 8
  • 7
15 Comments
 
LVL 19

Expert Comment

by:xterm
ID: 39679414
I'm running Horde/IMP too and it works fine on my tablet and phone - do you know if the site you're using is just using a very old version of the Horde framework perhaps?
0
 

Author Comment

by:christoforatos1968
ID: 39680014
How can i see this, if i am using an old version?
0
 
LVL 19

Expert Comment

by:xterm
ID: 39680040
Look in your webroot, horde/imp/lib/version.php

I'm running 4.3.3 which is fairly old too, but seems to display fine in all the mobile devices.
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 

Author Comment

by:christoforatos1968
ID: 39682117
Can you check if the link works on your mobile device.
The link is https;//mail.skygreece.com:83 .
0
 

Author Comment

by:christoforatos1968
ID: 39682215
The credentials are user name: test and password: 1234567
0
 
LVL 19

Expert Comment

by:xterm
ID: 39682270
I'm unable to pull up that page at all to even attempt to log in - is there a firewall preventing public access to it?  I tried it from multiple different source IPs...
0
 

Author Comment

by:christoforatos1968
ID: 39682758
Did you type it correctly.
https://mail.skygreece.com:83
0
 
LVL 19

Expert Comment

by:xterm
ID: 39682773
Sorry, I missed the port assignment on the end.

So, I can see what is happening here - evidently there is a mobile version built in, and it appears to be a bit broken.

On my Samsung Galaxy 10.1, it loads up and looks identical to how it looks in Chrome on my PC.  Works just fine.

However, on my phone (Droid Incredible 4G LTE) it has an undecorated login page, and when I authenticate, it just has a blank page with "welcome test" in the top left corner.

So it looks like the mobile version is broken.
0
 

Author Comment

by:christoforatos1968
ID: 39683006
What do you mean the mobile version is broken. Can you give me a workaround on this on how to find a solution. Looking forward to your feedback.
0
 
LVL 19

Expert Comment

by:xterm
ID: 39683858
Are you running a Plesk server?  cPanel?  Or just a generic Linux machine where you installed Horde yourself?
0
 

Author Comment

by:christoforatos1968
ID: 39684327
I am running ClearOS Enterprise. I guess it's a panel. The index.php does not load when logging into webmail.
I access the the linux machine through the ClearOS.
0
 

Author Comment

by:christoforatos1968
ID: 39685004
Do you have any feedback on this. I really need some help with this. Thanks.
0
 
LVL 19

Expert Comment

by:xterm
ID: 39692746
So when you load index.php, it runs a little detection routine on the User-Agent variable to determine if the visitor is a on a mobile device or on a regular PC.  If the user is on a mobile, they get directed to a different page which for whatever reason does not work on your installation - you might just need to upgrade Horde.

If you Google "Horde mobile blank page" you will see that some people are disabling the detection process, and just forcing all users to the regular mail interface (which works fine).  Will that option work for you?
0
 

Author Comment

by:christoforatos1968
ID: 39693360
That option would work for me. How do i upgrade Horde?
0
 
LVL 19

Accepted Solution

by:
xterm earned 500 total points
ID: 39693506
Upgrading Horde is going to be harder than my first suggestion, which is just to disable the browser check routine - whichever you want to do though.

This describes how to install a new version of Horde in ClearOS:
http://www.clearfoundation.com/component/option,com_kunena/Itemid,232/catid,14/func,view/id,29369/#29423
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Ubuntu not booting - How get past GRUB? 3 57
how to rebuild XFS volume from LV 19 89
Bash script - Exit out of choice loop 2 43
list of sudo access for date range 5 29
Fine Tune your automatic Updates for Ubuntu / Debian
Are client relationship the only driver of a successful MSP? While important, client relationships are only one component. Learn how else MSPs can broaden their horizon and differentiate themselves.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question