Changing RDS SSL Port on Server 2012R2

Hi All,

Having some difficulty setting up a different SSL port for our RDS Gateway.  The port has been updated as detailed in this TechNet article:

http://social.technet.microsoft.com/wiki/contents/articles/10972.changing-the-default-port-of-rd-gateway-in-windows-server-2012.aspx

Port forwards on the firewall for the 'newport' are in place & I can web surf to the RDS website at this address:

https://domainname:newport/RDWeb

When clicking on a published remote app however, the app fails to connect to the server.  Firewall logs show that the app attempted to connect of the default 443 port instead of the 'newport' specified in.  This process works internally without issues.

Is there a second location where the port must be specified so that it makes it way down into the remote app settings?  I've also published a new app since the update, thinking that it would take new settings, but it behaves the same way.

Thanks for your time!
mmeconsultingAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
mmeconsultingConnect With a Mentor Author Commented:
After taking  a break, I took this up again & found a resolution, hopefully this will save someone else a lot of searching in the future.

There is a power shell command that will change the gateway server address to whatever it needs to be, including the port switch.  I found the info here:

http://social.technet.microsoft.com/Forums/windowsserver/en-US/6ed0845a-1a51-4c05-8331-ece9c0eb73fa/remote-desktop-gateway-port?forum=winserverTS

You need to import the RD module into power shell via 'import-module RemoteDesktop' & then run the 'Set-RDSessionCollectionConfiguration' command with the switch for the custom rdp property.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.