?
Solved

MSSQL Job Agent running SSIS packages

Posted on 2013-11-27
7
Medium Priority
?
851 Views
Last Modified: 2016-02-11
Greetings, I have a SSIS Package with two variables.  The variables are hard coded in a SSIS package.  I have provided an image attached.

Here's the variables:
11-27-2013-2-44-14-PM.png
Here's the step:
11-27-2013-2-58-08-PM-0001.png
and here's the mapping:
11-27-2013-2-58-24-PM-0000.png
The package runs with no errors while in BIDS, but when I attach the package to SQL Server Agent, I get the error "Parameter name is unrecognized"

This is the first package I am deploying to MSSQL.  However, I have looked at already deployed packages, and they have variables, but nothing in the Job Settings.  The project works fine in BIDS.

What am I missing?  Thanks
0
Comment
Question by:Evan Cutler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 44

Expert Comment

by:Rainer Jeschor
ID: 39683053
Hi,
which SQL Server version and edition?
32 or 64 bit?

Thanks.
Rainer
0
 
LVL 9

Author Comment

by:Evan Cutler
ID: 39683619
I'm using 2008 64 bit, with this particular job running in 32 bit
0
 
LVL 25

Expert Comment

by:reb73
ID: 39686881
In the mapping try changing the value of 'ParameterName' from

?

to the ordinal

0
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 
LVL 9

Author Comment

by:Evan Cutler
ID: 39687018
ok...what's an ordinal?
and what do I change in the line of the command?

Thanks.
0
 
LVL 25

Accepted Solution

by:
reb73 earned 2000 total points
ID: 39688888
Ordinal is the order of the parameter list starting from 0.

The suggested change is in the parameter screenshot above, change the question mark to 0.
0
 
LVL 9

Author Comment

by:Evan Cutler
ID: 39688901
Ok. Please give me until Tuesday to try it. Visiting family for turkey day. Thanks
0
 
LVL 9

Author Closing Comment

by:Evan Cutler
ID: 39715471
don't know why this worked, but it did...
must be something I did...
Thanks.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently I was talking with Tim Sharp, one of my colleagues from our Technical Account Manager team about MongoDB’s scalability. While doing some quick training with some of the Percona team, Tim brought something to my attention...
In this blog post, we’ll look at how ClickHouse performs in a general analytical workload using the star schema benchmark test.
Via a live example, show how to backup a database, simulate a failure backup the tail of the database transaction log and perform the restore.
Via a live example, show how to setup several different housekeeping processes for a SQL Server.
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question