Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Xenpp App Server Load Balancing availability/Status going offline intermitently!!

Posted on 2013-11-28
5
Medium Priority
?
1,065 Views
Last Modified: 2013-12-12
We are running XenApp 6.0 Farm (All Vmware VM's) on Windows Server 2008r2 sp1 with XA600W2K8R2X64R01 HRP.
One of the Servers called "S2"in the farm keep dropping off the Load balancing table.

G:\>QFARM

Server               Transport Network Address
-------------------- --------- --------------------
S1         TCP/IP    172.30.8.62
S2*        TCP/IP    172.30.6.122
S3         TCP/IP    172.30.8.64
S4        TCP/IP    172.30.6.193


G:\>lbdiag Word 2007

Server Name         Server Load Server Address
------------------- ----------- --------------------
S1      3670        172.30.8.157
S3      6005        172.30.6.193
S2     OFFLINE



On QFARM /Load the server does not appear at all. "enablelb" command fixes the issue temporarily but I'm under pressure to find a permanent fix.

Any Help will be greatly appreciated...
0
Comment
Question by:Matsco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 9

Assisted Solution

by:VirastaR
VirastaR earned 664 total points
ID: 39683292
Hi,

Check this similar discussion

XenApp 6 member server keep being out of load balancing table

Hope that helps :)
0
 
LVL 1

Author Comment

by:Matsco
ID: 39683390
Thanks a mill! based on the advice on the post virastar referred me to I noticed right away that the Ctxsta.config UID was different from the Servers MAC . I will change monitor the server and report back. I am not sure if changing the CHM&R tests to just alert and not disable LB is a good idea but I consider it as a last resort.
0
 
LVL 16

Accepted Solution

by:
Joseph Nyaema earned 1336 total points
ID: 39683469
Look in event vierwer to see why HMR keeps kicking that particular server offline and post findings.

And eh...,  UID does not need to be the same as the MAC, just needs to be uniquie.  MAC addresses are always unique
0
 
LVL 16

Assisted Solution

by:Joseph Nyaema
Joseph Nyaema earned 1336 total points
ID: 39683503
0
 
LVL 1

Author Comment

by:Matsco
ID: 39713838
The issue happened again until I removed the server from the farm and re-added it after the STA fix. It been work fine for at lease a week now with no issues :)
0

Featured Post

The Ideal Solution for Multi-Display Applications

Check out ATEN’s VS1912 12-Port DP Video Wall Media Player at InfoComm 2017. Kerri describes how easy it is to design creative video walls in asymmetric layouts and schedule detailed playlists ahead of time with its advanced scheduling feature.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question