Solved

Xenpp App Server Load Balancing availability/Status going offline intermitently!!

Posted on 2013-11-28
5
991 Views
Last Modified: 2013-12-12
We are running XenApp 6.0 Farm (All Vmware VM's) on Windows Server 2008r2 sp1 with XA600W2K8R2X64R01 HRP.
One of the Servers called "S2"in the farm keep dropping off the Load balancing table.

G:\>QFARM

Server               Transport Network Address
-------------------- --------- --------------------
S1         TCP/IP    172.30.8.62
S2*        TCP/IP    172.30.6.122
S3         TCP/IP    172.30.8.64
S4        TCP/IP    172.30.6.193


G:\>lbdiag Word 2007

Server Name         Server Load Server Address
------------------- ----------- --------------------
S1      3670        172.30.8.157
S3      6005        172.30.6.193
S2     OFFLINE



On QFARM /Load the server does not appear at all. "enablelb" command fixes the issue temporarily but I'm under pressure to find a permanent fix.

Any Help will be greatly appreciated...
0
Comment
Question by:Matsco
  • 2
  • 2
5 Comments
 
LVL 9

Assisted Solution

by:VirastaR
VirastaR earned 166 total points
ID: 39683292
Hi,

Check this similar discussion

XenApp 6 member server keep being out of load balancing table

Hope that helps :)
0
 
LVL 1

Author Comment

by:Matsco
ID: 39683390
Thanks a mill! based on the advice on the post virastar referred me to I noticed right away that the Ctxsta.config UID was different from the Servers MAC . I will change monitor the server and report back. I am not sure if changing the CHM&R tests to just alert and not disable LB is a good idea but I consider it as a last resort.
0
 
LVL 16

Accepted Solution

by:
Nyaema earned 334 total points
ID: 39683469
Look in event vierwer to see why HMR keeps kicking that particular server offline and post findings.

And eh...,  UID does not need to be the same as the MAC, just needs to be uniquie.  MAC addresses are always unique
0
 
LVL 16

Assisted Solution

by:Nyaema
Nyaema earned 334 total points
ID: 39683503
0
 
LVL 1

Author Comment

by:Matsco
ID: 39713838
The issue happened again until I removed the server from the farm and re-added it after the STA fix. It been work fine for at lease a week now with no issues :)
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Last article we focus in how to VMware: How to create and use VMs TAGs – Part 1 so before follow this article and perform the next tasks, you should read the first article how to create the TAG before using them in Veeam Backup Jobs.
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now