Solved

Exchange Question

Posted on 2013-11-28
47
153 Views
Last Modified: 2013-12-09
Hi all I am following a guide on Multi Tenancy Using Exchange server 2010 SP2

can somebody tell me what this means and how I go about Changing the Permissions

Modified New-Tenant to grant the ALL USERS group for that tenant to be able to download the OAB for that specific tenant.

Thanks

John
0
Comment
Question by:pepps11976
  • 26
  • 20
47 Comments
 
LVL 8

Expert Comment

by:I Qasmi
ID: 39683491
0
 

Author Comment

by:pepps11976
ID: 39683508
Yes I have read through them but I cannot find the answer to my question in there, I have Multi Tenant setup, I am just having issues downloading a Newly Created OAB for that particular Tenant
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39683589
Please have a look to below, it may help you at some instance.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27690860.html
0
 

Author Comment

by:pepps11976
ID: 39683625
Yes the Article he Referred to is the one I used, I have done what fixed his problem but I still have the error
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39683743
What error you are getting can you please paste here ? and also check logs if any error, paste that as well.
0
 

Author Comment

by:pepps11976
ID: 39683767
This is the Error im getting in the Synch Log of the Exchange 2007 client

14:53:33 Microsoft Exchange offline address book
14:53:33              Not downloading Offline address book files.  A server (URL) could not be located.
14:53:33       0X8004010F

although I know this is not a URL issue because if create a user using the Default address policy OAB will synch fine
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39683785
Have you tried this IISReset /noforce as mentioned in above article.

You need to do below things then

In your Mailbox Databases you need to associate an offline address book.
You achieve this from the properties of your mailbox databases inside organization management -> Mailbox -> Database Management -> Right Click Properties -> Client settings

Add the default offline address book.  Then run the update address book and then restarted the exchange file distribution service and after few minutes later outlook via rpc over http will successfully download the address book.
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39683834
Also you can check below

get-offlineaddressbook  and check wht u get and after getting that URL, try to access that URL via IE and check what you get.

Also you can check below microsoft article and confirm for proxy setting any.

http://support.microsoft.com/kb/939765
0
 

Author Comment

by:pepps11976
ID: 39683836
Ahmed followed the steps to the letter still getting the issue
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39685012
You mean to say you have followed my both the latest comment as mentioned above including Microsoft Article ?
0
 

Author Comment

by:pepps11976
ID: 39685043
if I try to access the URL via IE I get a login prompt

We are not using Proxy server

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39685064
Have u also checked by executing below command.
Run:

Get-MailboxDatabase | ft name,offlineaddressbook

and check wht u get, can u see ur OAB here ?
------

If you not get your OAB after executing above command then you can try below things to bring that OAB back.

EMC > Organization Configuration > Mailbox

Database Management Tab > Right Click Mailbox Database  > Properties

Client Settings Tab > Offline Address Book field is Empty

Then browse and apply the \Default Offline Address Book

 

Now after running command Get-MailboxDatabase | ft name,offlineaddressbook

Name: Mailbox Database

Offline Address Book: \Default Offline Address Book
0
 

Author Comment

by:pepps11976
ID: 39685079
Executing That command gives me the Default address book
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39685152
The error you are getting for almost all users ?

please try to reboot the server and then check because everything else your seems to be fine so it should work.

Are you still getting the same error ?
0
 

Author Comment

by:pepps11976
ID: 39685156
The error only happens if I create a user and assign them a different Address Book Policy

if I create a User Mailbox using the Default settings ie Default Policy, then the OAB is downloaded

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39685163
so have u tried rebooting your server ?

have u tried changing the policy for existing user and check ?

can you also tell me that which exchange version u r using ? and on which platform
0
 

Author Comment

by:pepps11976
ID: 39685259
Yes rebooted server several times

Using exchange 2010 sp2 on server 2008

Can you change the policy for the user in management or is it a power shell command?

John
0
 
LVL 9

Accepted Solution

by:
Ahmed786 earned 500 total points
ID: 39685381
0
 

Author Comment

by:pepps11976
ID: 39685567
Yes I have followed this one also but still no luck

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39689541
Now everything you have tried then only few things have left, please try to create a new outlook profile and check whether it is taking the default OAB or not .

For existing Outlook profiles, you can manually change the OAB that is downloaded to the one that is built from the Global Address List.
•Outlook 2013 and Outlook 2010
1.On the Send/Receive tab, click Send/Receive Groups and then click Download Address Book.
2.In the Choose address book drop-down, select \Global Address List.
3.Click OK.
•Outlook 2007
1.On the Tools menu, point to Send/Receive, and then click Download Address Book.
2.In the Choose address book drop-down, select \Global Address List.
3.Click OK.

--------------------------

Other things you can try are as below, if above doesn't resolves then we can check below things if working or not.

Check whether Outlook and the computer can access the Offline Address Book file on the server. This action is typically done by Outlook in the background or when you force a download of the Offline Address Book in Outlook,

Follow these steps:
1.Start Outlook.
2.Hold down the CTRL key, right-click the Outlook icon in the notification area on the right side of the taskbar, and then click Test E-mail AutoConfiguration.
3.Click to clear the Use Guessmart check box, and then click to clear the Secure Guessmart Authentication check box.
4.Click to select the Use AutoDiscover check box.
5.Type the email address and password, and then click Test.
6.On the Results tab, note the path of OAB URL.
7.Click the XML tab, locate the <OWAUrl> and </OABUrl> tags, and then copy the path that's displayed between the tags. Paste the path into the address box in Windows Internet Explorer, add /OAB.xml to the end of the path, and then press Enter.

The following is an example of what the URL may resemble:
https://autodiscover.cont.com/OAB/93179f28-4b4d-4e58-aec1-07bb493be4f4/OAB.xml

8.Note the information that's displayed in the webpage in Internet Explorer. The webpage should contain lots of XML data, it should not come as SErver Error 404-file or directory not found.
0
 

Author Comment

by:pepps11976
ID: 39689609
Ok I have tried most of the above before currently I cannot browse the oab URL even on the exchange server, also testing auto discover from outlook used to work up until I starting changing things because of this issue, and now that's not working.

What's the easiest way to reset all virtual folders back to default so I can start from scratch?

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39689614
Have you tried this IISReset /noforce


You can refer this

http://technet.microsoft.com/en-us/library/ff629372(v=exchg.141).aspx
0
 

Author Comment

by:pepps11976
ID: 39689631
Yes I have done iis reset although I assume rebooting the server does the same thing?

The only reason I say start from scratch is because testing auto discover on the client used to work and show the oab directory etc but now it fails probably because I have tried so many things to try to get the address book to download changing permissions on the directories etc that now it is failing
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Author Comment

by:pepps11976
ID: 39692614
Ok I am back to where I started now I can setup email  using Auto discover.

if I create an email enabled user using Default Settings Default OAB is downloaded.

If I create a New address Book Policy and a new OAB then create a user and assign them that Adress Book Policy The OAB is not downloaded

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39692928
So now again from scratch

Execute below and see what you get.


Get-MailboxDatabase | ft name,offlineaddressbook


Do you get your OAB here


Also have check below things

EMC > Organization Configuration > Mailbox

Database Management Tab > Right Click Mailbox Database  > Properties

Client Settings Tab > Offline Address Book field is Empty

Then browse and apply the \Default Offline Address Book


Also please have a look to below article once again step wise and check you have not missed a single line.

http://www.msexchange.org/articles-tutorials/exchange-server-2010/management-administration/automating-multi-tenancy-exchange-server-2010-sp2-part3.html
0
 

Author Comment

by:pepps11976
ID: 39698329
Ok Running above command gives me the Default Offline Address Book Which is correct

EMC > Organization Configuration > Mailbox

Database Management Tab > Right Click Mailbox Database  > Properties

Client Settings Tab > Offline Address Book field is Populated with Default Address Book

still have synching Issues
0
 

Author Comment

by:pepps11976
ID: 39698402
Update.....

Ok it seems to be working with one users if I go into Send/Receive Address Book there address book says \Global Address List, this works.

if I do a send and receive on the others the address book that it is trying to download is
Default Offline Address List, this does not work although this is now the only address book I have

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39698502
Does it gives any error, have you checked logs ? or server n machine what it gives .

Also have u checked with other users, if all are facing the same issues ?
0
 

Author Comment

by:pepps11976
ID: 39698542
the errors on the ones downloading Default Offline Address Book are

15:59:01 Microsoft Exchange offline address book
15:59:01              Not downloading Offline address book files.  A server (URL) could not be located.
15:59:01       0X80004005

also the one user that was working where the address book Said Global Address List has also reverted back to downloading Default Offline Address Book and now has same error
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39698549
Have u tried changing as below.


•Outlook 2013 and Outlook 2010
1.On the Send/Receive tab, click Send/Receive Groups and then click Download Address Book.
2.In the Choose address book drop-down, select \Global Address List.
3.Click OK.
0
 

Author Comment

by:pepps11976
ID: 39698556
the only option I have in the drop down is 1 option which is Default Offline Address Book
0
 

Author Comment

by:pepps11976
ID: 39698562
Actually to be 100 percent accurate it says Default Offline Address Book list
0
 

Author Comment

by:pepps11976
ID: 39698620
Also is there a waiting period after changing things on the server after changing something I always restart the Microsoft Exchange File Distribution service
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39698644
Please go through below microsoft article then and in that go through resolution one and check if that make any changes.

http://support.microsoft.com/kb/2665915
0
 

Author Comment

by:pepps11976
ID: 39698672
Yes this is basically what you said earlier my Default OAB is not downloading any included address lists, and I do not have the option to select GAL it has one entry in the drop down which id Default Offline Address Book List
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39699145
So as per my understanding you have removed tick as mentioned in article, Right ?

Now what it says that any new Outlook profiles you create will use the OAB with the Global Address List by default.

And For existing Outlook profiles, you can manually change the OAB that is downloaded to the one that is built from the Global Address List.
Outlook 2013 and Outlook 2010
On the Send/Receive tab, click Send/Receive Groups and then click Download Address Book.
In the Choose address book drop-down, select \Global Address List.
Click OK.
0
 

Author Comment

by:pepps11976
ID: 39699571
ok this is what I am seeing one user gets only one selection in the drop down Which works

Working
the rest of the users only have this option that does not work

Not Working
all users are the same is as far as exchange users etc so why do they see different things?

john
0
 

Author Comment

by:pepps11976
ID: 39699640
Right I think I know what the issue is but I don't know how to fix it.

The domain of the exchange is domain.local all users receive this address when created, on the server we have added a domain as an accepted domain and these users have this other domain as there Set As Reply Addresses and I think that is why they are not downloading the address book.

I think I have proved this by creating a user with the standard domain as the reply address and it works, then on the same machine with same outlook etc created a user who has the other domain as there reply email address and it fails.

could this be the reason?

and if so how do I get around this

john
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39700479
Yes you are right, this can cause problem when settings are not done properly.

Does all was working fine prevously ?

Then, what changes you made which cause this problem ?

Can you first please provide exact details as below.

1> How many exchange servers you have and is it 2007 or 2010 ?

2> How many  Domains you have ? such as abc.com & xyz.com

3> What you get when you execute below command

Get-AcceptedDomain ¦ fl domainname, *type*
0
 

Author Comment

by:pepps11976
ID: 39700588
Basically this is a Exchange 2010 SP2 Server that used to host 1 Domain, the domain.
Then to help a couple of small companies out we said we would host their email for them. which are obviously a different domains.

We have 1 Server Ex2010 SP2
Setup as one Domain = domain.local

The command you posted just seems to hang and does not output anything

IN EMC we have 5 Accepted Domains and the domain.local is the default the others are all Authorative

John
0
 

Author Comment

by:pepps11976
ID: 39700892
Any More Thoughts?

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39701015
You need to have look on below article by Rajeev Sharma and also have below microsoft article.

It will guide you to things what you have done with your organization and what should be done properly to handle multiple Acceptain Domains and how adress policy should be created for each accepted domain to work.

http://forum.gotzu.com/showthread.php?tid=81

http://technet.microsoft.com/en-us/library/bb124423(v=exchg.141).aspx
0
 

Author Comment

by:pepps11976
ID: 39701031
Ok I have read these articles before but this would not stop my problem from happening, this is just explaining hot to not Manually have to edit user email addresses by creating Email Policies.

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39701354
As you said earlier that when you create a user and when it is set as domain.local as set as reply then it works, m i right ?

Then you said that users created with other Domain as set as reply then it DONT work, m i right ?

So how u are saying that you have only one Domain as Domain.local ??

You can atleast try below command

Get-AcceptedDomain ¦ fl


Finally its good to have SP3 for your Exchange 2010 with Rollup Update 3 (Now Available)
0
 

Author Comment

by:pepps11976
ID: 39701387
Domains
These are the domains we accept mail for however they only access their Mail Through OWA so they will not Get OAB Issues

If the users default send as email address is user@linkitsupport.co.uk OAB is fine

if the users send as address is user@aspireclinic.com which ia the only users who use Outlook anywhere OAB errors

John
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39704822
Do it for the one who has issue with OAB and give a try.
Can you please try to Erase the Offline Address Book (...\AppData\Local\Microsoft\Outlook\Offline Address Books)

And then Force Outlook to download it again

---------------------

Also you can try disabling the cached Mode and check if that works ?

You are using Outlook Anywhere so forget about above "cached mode"

 Please try below connectivity test and check whether it gives any error ?

https://www.testexchangeconnectivity.com/

------------------


Also It could be problem with Autodiscover DNS record

Make sure that , Autodiscover.yourdomain.XXX is accessable from inside as well as outside.

Note :- IF you do anychanges related to DNs, you need to flush your DNs on client and on server.
0
 

Author Closing Comment

by:pepps11976
ID: 39706350
Although I am marking this as the answer whoever decides to host multiple domains on Exc 2010 SP2 the Various domains using Outlook Anywhere must have there Auto discover domain name added to the Certificate other wise this will not work, this had me stumped for 2 Weeks!
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now