Autounattend.xml, Re-arm, KMS and Windows 7

We are currently implementing a KMS server.

I have created an image and applied an autounattend.xml file for sysprep.

I suspect that the settings I have in there are wrong.

I believe they are wrong because once the image has rebooted I am having to run slmgr /rearm, reboot, run slmgr /ato, reboot for Windows 7 to be activated.

The section I think is responsible is this :

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="generalize">
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipRearm>1</SkipRearm>
        </component>



Am I right in my assumption and how do I correct this please ?
SimplesAsked:
Who is Participating?
 
Jason WatkinsConnect With a Mentor IT Project LeaderCommented:
have you tried with a file named "unattend.xml"? In my experience, that is the only file name Windows' sysprep picks-up.
0
 
Jason WatkinsIT Project LeaderCommented:
The re-arm section there allows you to keep sysprepping Windows 7 before it times out. One can only sysprep a Windows install a certain number of times. 3, I think it is.

See step seven here, which takes you through sysprep from start to finish.

http://theitbros.com/sysprep-a-windows-7-machine-%E2%80%93-start-to-finish/
0
 
SimplesAuthor Commented:
Sorry but that doesn't really answer my question. That is a general how to sysprep guide.

 What I need is how do I stop having to run the slmgr commands before the PC will be licenced?

I don't want to have to run those commands on many hundreds of PC's
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Jason WatkinsIT Project LeaderCommented:
Add the following to your unattend.xml file

Under oobeSystem, amd64_Microsoft-Windows-International-Core_6.1.7600.16385_neutral


FirstLogonCommands

CommandLine: cscript /b c:\windows\system32\slmgr.vbs /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX (windows 7 license key)
Order 1
RequiresUserInput: false
CommandLine: cscript /b c:\windows\system32\slmgr.vbs /ato
Order 2
RequiresUserInput: false

SynchronousCommand[Order="1"]

SynchronousCommand[Order="2"]
0
 
SimplesAuthor Commented:
Thanks but that didn't work. It parses OK but I still have to run those slmgr commands. The section of xml is below so I'm hoping you can see what I have done wrong (we are on x86 by the way):

<settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <AutoLogon>
                <Password>
                    <Value>Blah blah blah=</Value>
                    <PlainText>false</PlainText>
                </Password>
                <Enabled>true</Enabled>
                <LogonCount>1</LogonCount>
                <Username>Administrator</Username>
            </AutoLogon>
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <NetworkLocation>Work</NetworkLocation>
                <SkipMachineOOBE>true</SkipMachineOOBE>
                <SkipUserOOBE>true</SkipUserOOBE>
            </OOBE>
            <UserAccounts>
                <AdministratorPassword>
                    <Value>Blah blah blah =</Value>
                    <PlainText>false</PlainText>
                </AdministratorPassword>
            </UserAccounts>
            <WindowsFeatures>
                <ShowMediaCenter>false</ShowMediaCenter>
                <ShowWindowsMail>false</ShowWindowsMail>
            </WindowsFeatures>
            <FirstLogonCommands>
            CommandLine: cscript /b c:\windows\system32\slmgr.vbs /ipk FJ82H-XT6CR-J8D7P-XQJJ2-GPDD4 ( Key is in the Public Domain )
            Order 1
            RequiresUserInput: false
            CommandLine: cscript /b c:\windows\system32\slmgr.vbs /ato
            Order 2
            RequiresUserInput: false
            SynchronousCommand[Order="1"]
            SynchronousCommand[Order="2"]
          </FirstLogonCommands>


Thanks
0
 
SimplesAuthor Commented:
Bingo !
500 points gratefully coming your way. An excellent result, thank you very much.
0
 
Jason WatkinsIT Project LeaderCommented:
Glad to help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.