Solved

LAG between Cisco 3750G and SG-300 switch

Posted on 2013-11-29
12
2,044 Views
Last Modified: 2013-12-10
I'm trying to setup LAG between a Cisco 3750G (core) switch and 4 SG-300s. I've read several setups but nothing seems to work. Currently the physical cables are connected (2) and I'm letting STP keep things straight.

What my goals are is to have two physical ports on the SG-300 (Last two on switch) connect via a static LAG as that is what I've got configured (static) between my two 3750s and a a 2960 statck.
I do run vlans on these switches.
The switches marked "tlr","adm","FO","BO","IT" are all SG-300s, either 28 or 52 port.
The 2960 is a stack arraignment.
All SG-300s (except IT) have two vlans setup vlan1 (default) and one other (7,8,9,10).
2960 has only vlan1 and is working properly.

I have tried various combinations of LAG setup on the SG-300s and usually end up killing my connection and I have to physically reboot switch to get connectivity back (I won't save config until it's working)

On the 3750G the relevant port-channel configurations are shown. All port-channels on the 3750 for thhe SG-300s are the same with just the vlan info different.

3750G----------
port-channel load-balance src-dst-ip
......
vlan 7
 name wales-tellers
....
interface Port-channel7
 description Trunk Group Ports SG-300 Tellers
 switchport trunk encapsulation dot1q
 switchport mode trunk
.........
interface GigabitEthernet1/0/1
 description Vlan 7 Primary
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,7
 switchport mode trunk
 channel-group 7 mode desirable non-silent
..
interface GigabitEthernet1/0/2
 description Vlan 7 Secondary
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,7
 switchport mode trunk
 channel-group 7 mode desirable non-silent
......

I've also tried channel-group 7 mode active and on.
I'm trying "NOT" to use LACP and according to the documentation I don't have to.

Thanks.
After-re-configure.vsd
0
Comment
Question by:RichardPWolf
12 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 39686200
Start over on your port channel config.

Start by putting the very basic config needed on the member interfaces:

interface GigabitEthernet1/0/1
 description Vlan 7 Primary
  channel-group 7 mode on
..
interface GigabitEthernet1/0/2
 description Vlan 7 Secondar
  channel-group 7 mode on

Once the port channel is created. Apply all other configs to the port channel only and they should flow down to the member interfaces. Nevertheless, the port channels and member interface configs should match other than the channel-group command.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39686203
Also, make sure that the S300 port channels match on the other end or the port channels won't come up.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39686361
I'm trying "NOT" to use LACP and according to the documentation I don't have to.
Why is that?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39686763
You're right, you don't HAVE to use LACP, but if your devices support it I don't see why you wouldn't want to?  It's probably the better bet to use LACP than static LAG as IIRC the SG switches will use LACP by default.

When creating EtherChannels...

mode on = static LAG
mode active/passive = LACP
mode desirable/auto = PAgP

Your config is using PAgP, which is not static LAG.

Soulja is correct - you should have the same PortChannel config as the member ports (apart from the channel-group command).  Give what Soulja said a try, and if that doesn't work try this...

interface Port-channel7
 description Trunk Group Ports SG-300 Tellers
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,7
 switchport mode trunk
.........
interface GigabitEthernet1/0/1
 description Vlan 7 Primary
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,7
 switchport mode trunk
 channel-group 7 mode active
..
interface GigabitEthernet1/0/2
 description Vlan 7 Secondary
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,7
 switchport mode trunk
 channel-group 7 mode active

Open in new window


The PortChannel number doesn't have to match at each end though.  You can use PortChannel1 at one switch and PortChannel5 at the other switch and it will work.
0
 

Author Comment

by:RichardPWolf
ID: 39690401
Solved, found that I wasn't letting switch "sit" long enough and also found I needed to add my vlans to the lag and not the ports.
0
 

Author Comment

by:RichardPWolf
ID: 39696514
I've requested that this question be closed as follows:

Accepted answer: 0 points for RichardPWolf's comment #a39690401

for the following reason:

It took me long enough and many Sunday's because any time I made a change it bumped the entire network whicha I still don't have an answer to.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:RichardPWolf
ID: 39690427
All good
0
 
LVL 26

Accepted Solution

by:
Soulja earned 500 total points
ID: 39690533
I believe this should warrant points to be rewarded. Based on authors closing comment:

"Solved, found that I wasn't letting switch "sit" long enough and also found I needed to add my vlans to the lag and not the ports. "


I stated this here:

"Once the port channel is created. Apply all other configs to the port channel only and they should flow down to the member interfaces."
0
 

Author Comment

by:RichardPWolf
ID: 39696481
All switches working in LAG.
0
 

Author Closing Comment

by:RichardPWolf
ID: 39696515
OK, re-doing points.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39696622
Thank you.
0
 

Author Comment

by:RichardPWolf
ID: 39708405
One last comment. I do want to apologize to Craigbeck. After more research and specifically re-reading this post he should have been awarded some points also. Because of my lack of understanding of LAGs his pointing out the differences between the different modes is what finally got things to work. There is a lot of conflicting documentation out there on the web that I got totally confused as to what needed to be set.

Again thank you all for your help.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
cisco ubr7200 problem with  interface Wideband-Cable 1 36
PORT NUMBER FOR FIOS ROUTER 5 50
Cisco iWAN 8 71
No RSTP between switches 3 46
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now