Solved

hot to open ports to opensuse 11.4

Posted on 2013-11-29
8
1,027 Views
Last Modified: 2013-11-29
Hi, i am an starter in linux and need to make sure the port 3389 is open for outbound connection, because i want to use remote desktop to connect to one server outside of our network and i think the firewall on opensuse is bloking the port 3389. Can you guys help me step by step on the command line i need to execute on the linux. i will count on you all.
0
Comment
Question by:rafaelrgl
8 Comments
 
LVL 30

Expert Comment

by:IanTh
ID: 39685810
The procedure for opening ports in the Linux firewall "iptables" is relatively simple.

 First, open a command-line terminal.  In most systems, you can usually find this in your 'Applications' menu under the 'System Tools' section.

 Once you have a terminal open, you have to obtain root access to change firewall settings.  Do this by typing:


su -


 You will be prompted for your root password.

 In the following examples, substitute the port # you want to open for the 12345 in the command.

 If you want to open an incoming TCP port, type the following:


iptables -I INPUT -p tcp --dport 12345 --syn -j ACCEPT


 If you want to open a UDP port (perhaps for DHT in Tixati), type the following:


iptables -I INPUT -p udp --dport 12345 -j ACCEPT



 After you are done opening ports in your firewall, you can save your changes so they will be applied when you restart your computer by typing the following command:


service iptables save
0
 
LVL 19

Expert Comment

by:xterm
ID: 39685947
There is no default outbound firewall in OpenSUSE, but just to be sure, please run and paste here the output of the following command, and we can tell you if 3389 is restricted in any way:

/sbin/iptables -nL
0
 
LVL 21

Accepted Solution

by:
Mazdajai earned 500 total points
ID: 39685961
Is the server acting as a firewall in your environment? You mean inbound poty?

To open tcp/3389 with iptables:
iptables -I INPUT -p udp --dport 3389 -j ACCEPT

Open in new window


I would first make sure you can connect within the same network beforehand.
0
 
LVL 1

Author Comment

by:rafaelrgl
ID: 39686270
i can connect with the same network normally, but when it's outside is then blocked. just don't know why.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 21

Expert Comment

by:Mazdajai
ID: 39686283
"Outside" as in outside the firewall / corporate network?
0
 
LVL 1

Author Comment

by:rafaelrgl
ID: 39686294
what's the command i should execute on the linux to make the firewall open for outbound connections. like example:

i can access from outside the network the server normally using remote desktop, and also i can use one computer inside the network to access another computer inside the network using remote desktop, but what i want is to use one computer inside the network to access another computer outside the network. it's like the outbound connection is block but incumming connection is open.
0
 
LVL 1

Author Comment

by:rafaelrgl
ID: 39686298
lets say i have network 192.168.0.X and this network is the company network. So using this example.

I can access another computer using remote desktop connection using computer 192.168.0.1 to 192.168.0.X

I can access computer inside the network 192.168.0.20 using my home computer that is outside the network.

I can't access another server outside the network using computer 192.168.0.20 to access another computer on the internet. This one here does not work.
0
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39686307
See my previous thread on how to open tcp/3389 for inbound connection.

You should check with the network guys to see if there an ACL configured on the firewall side.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Teach the user how to configure vSphere Replication and how to protect and recover VMs Open vSphere Web Client: Verify vsphere Replication is enabled: Enable vSphere Replication for a virtual machine: Verify replicated VM is created: Recover replica…
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now