Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 327
  • Last Modified:

Pointing mouse in right corner of Windows 8 seldom works

Got a new Toshiba Satellite with Win 8.  It is at work and I have to access it remotely.  Pointing my mouse anywhere on the right side seldom works.  

Any ideas.

Is there another way to get to the start screen?
0
J.R. Sitman
Asked:
J.R. Sitman
  • 4
  • 2
  • 2
  • +2
2 Solutions
 
JohnBusiness Consultant (Owner)Commented:
There should be a little square at the left of the taskbar. Click on it and you should get to the start screen. Also press your Windows key (left of the spacebar usually). That also takes you to the start screen. Both should work remotely.

.... Thinkpads_User
0
 
aadihCommented:
You could try:  ALT+HOME key combination.
0
 
J.R. SitmanIT DirectorAuthor Commented:
Neither of the 3 suggestions worked.  Pressing the Windows key brought up the Start menu on my home PC.  I don't see a a square on taskbar.  See attached.  ALT home did nothing.
win8.png
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
JohnBusiness Consultant (Owner)Commented:
Consider upgrading to Windows 8.1. That adds an actual Start Button on the left of the taskbar that works reliably.

However, you say above that on your Toshiba Satellite that the Windows Key does not work?  Strange.  You should contact Toshiba about that.

... Thinkpads_User
0
 
aadihCommented:
See if the following reference helps:

http://windows.microsoft.com/en-us/windows-8/remote-desktop-connection-faq >

How do I open the Start screen and charms when I connect to a remote Windows 8.1 PC from a Windows 8.1 PC?

Use the connection bar that appears at the top of the screen to open the remote PC's Start screen, charms, recent apps, and to use Remote Desktop Connection side by side with other apps.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I tried to upgrade early today to 8.1 but the Store was having issues.

To clarify I'm accessing it remotely, so my local keyboard usually takes precedence.
0
 
Steven HarrisPresidentCommented:
To clarify I'm accessing it remotely

Built-in Remote Desktop Connection?  Third-party program?

With the built-in RDC, you should have a 'Charms' option where you normally find the 'Send Ctrl+Alt+Del' command.
0
 
Paul JacksonSoftware EngineerCommented:
Windows Key + C is shortcut to open charms bar
0
 
Paul JacksonSoftware EngineerCommented:
CTRL + ESC returns you to Start screen
0
 
J.R. SitmanIT DirectorAuthor Commented:
I connect to our Long Beach location using RDP, then I use Dameware to connect to the PC.  You got  me thinking.  I disconnected Dameware and used RDP.  Then I had the options at the top.

Thanks
0
 
J.R. SitmanIT DirectorAuthor Commented:
Thanks to all for helping
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now