Removing Responsivity from Website

I initially designed my website to be responsive but have since not had the time to take it all the way to completion. In the meantime I would like my site to appear the same in all browsers & phones, ie remove all responsive features. How do I achieve this on http://www.stoneflypress.com?


Thanks in advance for any help!
Khel
LVL 1
khellarAsked:
Who is Participating?
 
GaryConnect With a Mentor Commented:
Then remove maximum-scale=1.0, user-scalable=no from the meta tag - this will allow the phone to zoom it to fit on the page.
0
 
GaryConnect With a Mentor Commented:
Add to the end of your css

.container{
min-width:940px
}
0
 
khellarAuthor Commented:
iphone screen shot of background image way too small

Thank you I did add this code to the end of my css and on my iphone I'm still seeing the site zoomed in to just the logo with the entire bg fit to that zoomed in view. Then when I zoom out, the background on the page and on the footer are stuck at the original width. How do I set the zoom to the full width of the page when the iphone user lands there? I feel like this may have been set manually by our first developer but I don't know what code controls it.

Thank you Gary for your help!
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
GaryConnect With a Mentor Commented:
If you want to prevent scaling, which all phones will do anyway, and force the site to the actual pixel dimensions then you need to disable it

Amend your meta tag with the bolded

<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
0
 
khellarAuthor Commented:
Ok thank you for the help. I did try that code and the page comes up still zoomed in -  only now I can't zoom out and the background image is still sized down in the top left size of the screen when I scroll around. Any other suggestions?
0
 
GaryConnect With a Mentor Commented:
It may be a cache thing in the browser, working fine on my mobile here...
And on #wrapper {} (styles.css line 43) add min-width: 940px;
0
 
khellarAuthor Commented:
Looks like you were right here Gary! The background is now reaching all the way across the site and after I changed user-scalable to 'yes' I was then able to zoom in and out like I wanted. The only thing that is still not working the way I'd like it to is that the site is zoomed in when it loads. Is there any way to get the site to load so that the full width of the site fits in the mobile viewer (ie zoomed out)? Really appreciating the great input!
0
 
khellarAuthor Commented:
Also now this section of the site is having problems with it's appearance: http://stoneflypress.com/blog/

Is that because it doesn't use #wrapper or .content?
0
 
GaryCommented:
Confused now...
Do you want the site to be a static 940px wide or scalable?
0
 
khellarAuthor Commented:
Sorry for the confusion Gary. On an iphone the site should be zoomed out so the whole 940px container fits on the available screen space, then the user should be able to zoom in and out. Maybe I'm not understanding how to ask for that because I don't know how the code works, but hopefully you're getting my drift.

Thanks :)
Khellar
0
 
khellarAuthor Commented:
Bingo. Site looks perfect now on iPhones. Thanks so much!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.