file explorer

i'm looking for info on how to remove the USERNAME (shortcut to c:\users\{username}) folder from the left sidebar in windows 8.1 file explorer & windows 7.

also am wanting to remove Homegroup from the left sidebar in windows 8.1.

thanks
LVL 25
dgrafxAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Ram BalachandranConnect With a Mentor Commented:
If this computers are in Domain you can use group policy to customize your interface.

Else,

how to remove home group  : Step by Step process >> Click here

Customise Windows Explorer for better performance >>CLICK HERE
0
 
John HurstBusiness Consultant (Owner)Commented:
To remove username go to Computer, right click, Properties, Advanced System Settings, click on User Profiles and remove (delete) the profile.  Restart and the profile should be gone.

If you do not want HomeGroup to show up, you can disable it (Network Settings, Advanced Settings). If you want HomeGroup enabled, then it will show up.  It does not show up on my own Windows 8.1 machine with HomeGroup disabled.

.... Thinkpads_User
0
 
John HurstBusiness Consultant (Owner)Commented:
The asker is try to remove a profile, not customize Windows Explorer.

.. Thinkpads_User
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Ram BalachandranCommented:
Thinkpads_User - Why user need to delete profile here  ? [as user mentioned :left sidebar in windows 8.1 file explorer & windows 7]
I believe user is trying to customize the explorer. Remove link and delete profile both are different
0
 
John HurstBusiness Consultant (Owner)Commented:
@dgrafx  - Your post implies remove the folder (I thought). If you do not want to have the folder appearing, you can go to Personalize, Desktop Icons and remove it there as well.

.... Thinkpads_User
0
 
dgrafxAuthor Commented:
Thanks
ram_kerala - am using your solution to remove homegroup from explorer sidebar.
solution was to stop & disable homegroup listener & provider in services.
Thanks - even though I had left the homegroup (and wasn't using one actually) the icon still remained.

for the "username" folder issue:
I am not wanting to remove a user - I am wanting to remove the folder from showing on the left sidebar in explorer.
thinkpads_user - where you say to go to personalize > desktop icons - that adds removes from desktop only - not from explorer sidebar.

Thanks
0
 
Ram BalachandranCommented:
Not sure if you are trying to hide navigation bar.
In that case - Click on Organise in the Explorer Window > Layout > Uncheck Navigation Pane
How to Disable Navigation oane
0
 
dgrafxAuthor Commented:
no i'm not trying to hide the navigation bar ...

just the folder in question.
0
 
Ram BalachandranCommented:
Can you please send a screenshot - sorry i am not able to find that in my machine
0
 
dgrafxAuthor Commented:
See attached image.
I'd like to hide the folder named (in this case because that's the logged on user) Administrator from showing in the left sidebar in explorer.

Thanks
sidebar.png
0
 
Ram BalachandranConnect With a Mentor Commented:
Tools > Folder Options > Navigation Pane [ in Bottom]
Uncheck show all folders
Uncheck automatically expand to current folder

--
0
 
Ram BalachandranCommented:
A registry tweak is required to delete Home Group. This need to be done carefully.
Ensure you take registry backup before doing this


Start >Run > regedit  and navigate to

HKEY_CLASSES>ROOT\CLSID\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}\ShellFolder.

Before you edit anything, you'll need to get permission to do so. Right click on "ShellFolder" in the navigation pane and hit Permissions.
Select the current user and check the "allow" box under Full Control.
Hit OK and go back to the editor.
Double click on "Attributes" in the right hand pane and change the value from b084010c to b094010c.
Click OK, exit the registry editor, and log out.
 

Reference : click here
0
 
John HurstBusiness Consultant (Owner)Commented:
@dgrafx  - Administrator should not be on the Windows Explorer Sidebar in any event.

Did you enable the Administrator Account?  It should be disabled and it will not show.
Did you disable UAC?  That should be enabled.

Did you get to Windows 8.1 by upgrading a Windows 8 machine?  That has gone wrong for a number of people and may have here as well.

.... Thinkpads_User
0
 
dgrafxAuthor Commented:
thanks guys
>>ram_kerla - as I had already stated, I used the first link you posted to hide the homegroup - thanks.

>>thinkpads - there may be a misunderstanding here.
yes the Administrator account is enabled - on purpose - and that is the account I use.
and as far as I've seen the "username" folder is visible in the sidebar on both win7 and win8 - I don't recall if it showed in xp.
and since I was asking the homegroup question I thought I'd finally ask about removing that folder as well.
i've seen posts on how to remove favorites or libraries et cetera - but never what I'd asked here so am glad I asked.
0
 
John HurstBusiness Consultant (Owner)Commented:
In Windows 7 and 8 the Administrator account should remain disabled for security purposes. There is no need to enable it and all my client systems run with it disabled with no difficulties. That is why is shows up on your Windows Explorer.

You should set up an account to use and make it a member of the administrators group. Then your problem will go away.

Homegroup will appear if you enable it and I don't think you can stop that.

.... Thinkpads_User
0
 
dgrafxAuthor Commented:
>>thinkpads
IF i created a new user named XYZ and then logged in as XYZ I would then see a folder in the left sidebar in explorer named XYZ - which I would now then be asking how to hide ...
the issue would still exist.

note how all along i have been saying the "username" folder because I didn't want someone to say the dgrafx folder - what's that? i don't have that folder.

and there are no valid reasons why I myself would not use the built in administrator account.
a created account that is a member of the administrators group is limited.

thanks though for your time
0
 
John HurstBusiness Consultant (Owner)Commented:
The folder with the main user account (XYZ in this case shows up). That is the way Windows 8 was designed. I happen to use it, so I leave it there.  I rename the folder on the desktop (I call it Computer) and that is what shows up in Windows Explorer on the left side. So I manage the situation within Windows 8 limits and it seems to work fine.


and there are no valid reasons why I myself would not use the built in administrator account.

You have to be perfect to survive. An errant click on a website could hose your computer. It happened all the time in XP (which appears to be where you came from) and Microsoft changed this years ago by disabling the Administrator account. It works for 99% of us (probably more) so it can work for you also.

... Thinkpads_User
0
 
joinaunionCommented:
So when you right click the folder do you see target(start in) or location tab?

If you do you can change the location to where you would like it to be.

For example you can create a folder called c:\whatever

Then change the location to c:\whatever
0
 
dgrafxAuthor Commented:
in win8 to not show all folders you right click in left sidebar to show all folders option - fyi
0
All Courses

From novice to tech pro — start learning today.