Solved

Cannot Connect to Vmware Management Port after Upgrade

Posted on 2013-11-30
14
1,302 Views
Last Modified: 2016-11-23
I have just recently upgraded an entire vcenter system from 4.1 to 5.1. As well as 10 hosts in 1 site and 1 in the other site.
All seemed to go rather well except for the 1 host in the remote site.
I cannot connect to the management port of the host, however when it was first upgraded I could. Not until I upgraded the vsphere tools on the VMs on the host did I lose the connection.
The VMs running on the host are still all connected and working.
In vcenter the host shows as offline and I cannot ping the IP address of the host.
I have tried restarting the management connection and also the whole server.
I did notice last night when I turned off the VMs that after about an hour I could connect to the management port, but then lost the connection again after about an hour.
I can login to the server via ilo so have been able to troubleshoot from there
I tested the management port from the host and I can ping the default gateway but no further. From other servers I can ping the same default gateway but not the host management port.
The host is in a vlan which is properly configured from what I can tell. Especially as it was working before the upgrade.
I have had the networking team investigate and they have confirmed the switches and vlans are correct but they cannot connect to the actual host, although the port on the switch shows it is active.
I have tried disabling the vmtools on the VMs on the host but this has had no effect.
The management port has 2 network connections with 1 running in standby, I have also tried setting the standby as active but to no avail.
The host itself is showing it has properly updated to the correct version of 5.5
The server is an HP DL380 G7 about 2 years old
I can connect to the host via ilo and have even tried changing the IP address which had no effect, as I thought maybe there was an IP clash
The differences between this host and the other hosts is it is HP and the others are Dell, also for the upgrade I upgraded the Dell servers via upgrade Manager, and the HP was initiated by upgrade manager but as there was an upgrade disk in the server I accidentally upgraded it from that, but this still seemed to upgrade fine.
Any help is much appreciated
0
Comment
Question by:CodeBlueEngineers
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 

Author Comment

by:CodeBlueEngineers
ID: 39687675
Also forgot to mention the connection seems to be intermittent, ie last night I was able to connect for about an hour, then lost the connection again
0
 
LVL 120
ID: 39687877
if you can get onto the host via iLo, can you ping the default gateway?

is the default gateway set correctly?
0
 

Author Comment

by:CodeBlueEngineers
ID: 39688004
Hi there, yes I can ping the default gateway but no further. The strange part I do not understand is from other servers I can ping that same DG and it is definitely correct.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 120

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 39688104
This appears to be a routing issue?
0
 

Author Comment

by:CodeBlueEngineers
ID: 39688187
I have had our networking team investigate and they have said the switching and routing is correct, and that when connected directly to the switch they cannot connect to the host.
Its strange that it happened directly after the upgrade as well.
0
 
LVL 120
ID: 39688405
There have been some networking changes in 5.1 between vmkernel and management network routing.
0
 

Author Comment

by:CodeBlueEngineers
ID: 39688531
Thanks, I have logged a job with vmware so hopefully they can find the issue. If its to do with the network routing or vmware changes as above I will allocate you the points
0
 
LVL 120
ID: 39688630
Upload your networking screenshot.
0
 

Author Comment

by:CodeBlueEngineers
ID: 39688641
Just uploaded now, just had to cover the names of the servers.
As you can see VM's and management use the same network port.
Which is strange that it works for the VM's but not the management network
vmware-networking.PNG
0
 
LVL 120
ID: 39688682
What is glaringly obvious is the host is on a different VLAN

Check vlan configuration is correct on the trunk eg physical network config. On physical switches connected to host server and all other switches in network.

You also have a single nic with all traffic running over....so check whatever config is running on this.

Seems a little on the light your vSwitch I would trunk both NICs so both active active
0
 

Author Comment

by:CodeBlueEngineers
ID: 39688696
Yes that does seem to be what is very obvious, I have the networking team checking out the switching and vlans.
Do you think there may be a chance that the management port is being flooded?
0
 
LVL 120
ID: 39688749
We are fans of the management port on its on vSwitch0 with at least two NICs.

Same for VMs its on vSwitch1 with two NICs.

Now you have VLANs which are fine but VLAN diagnosis and asking a network team for virtualization on a specific VLAN needs specific network probes on each vlan and specialist monitoring which your network tram may have so ask them for utilisation figures for each vlan

And of course that's not errors or a total value for the pipe.
0
 

Author Comment

by:CodeBlueEngineers
ID: 39691358
Just found there is another device on the same subnet which has the same IP address as the default gateway.
Once we removed the device it started working straight away
So you were right hanccocka it was network related
0
 
LVL 120
ID: 39691402
Glad it was resolved!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I show you step by step with screenshots to assist you - HOW TO: Deploy and Install the VMware vCenter Server Appliance 6.5 (VCSA 6.5), with some helpful tips along the way.
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question