Windows Hyper-V host losing time

I have a really strange problem.  I have a Hyper-V host that hosts 2 virtual servers.  One is a SBS2011 server.  The host is losing time.  30 minutes a day.  What is really puzzling is this host is a new server, that replaced another server that had the same issue.  On the old server, I replaced the battery on the MB, and even replaced the motherboard, but the time problem continued.  This is a new Dell R515 with dual quad core, 32 gigs.  There is a Netgear GS724T gig switch, and a Cisco ASA5505 firewall.  I can't figure out what is going on.  The time will get further behind as time passes, so it isn't logical that is is getting time from somewhere else, since the time will get progressively further behind.

Any ideas?
Who is Participating?
George SimosConnect With a Mentor IT Pro Consultant - IT Systems AdministratorCommented:

The first question that comes to my mind is: "Do you update your Hyper-V Server? Have you installed the latest patches for it (all of them not just critical only).
The second question is: "Have you tried to sync this Server's time service with an external time source?"
If your server has access to the internet or you have a server/switch/router that syncs its time from an external source then you should try first doing this and check what is the outcome.
You can setup the time service by running the command:
w43tm /config /update /register /syncfromflags:manual /manualpeerlist:ListofComputerNames/IPs

Open in new window

Where "manualpeerlist" is a "space" separated list of fqdn server names or IP addresses that will be used for the time synchronization.
if you add more than one servers then enclose the space separated list in "", e.g.:

Open in new window

More about Windows Time Service here .
Also your SBS should be sync from an external time source and as a best practice you must uncheck the Time sync integration service from the VM's Settings.
Hope these will help you.

P.S. You haven't mentioned which version of Hyper-V you are running....
Svet PaperovIT ManagerCommented:
Is this host part of a domain? If yes, is the domain controller holding PDC role hosted on the same host? If that’s the case, you should configure the host to synchronize time with external source (by default, all domain members synchronize the time with the PDC role holder).

If it’s doesn’t help, try updating the BIOS of the host server.
JackAitkenAuthor Commented:
The host is part of the domain, as it also hosts a tape drive for backup.  If I recall, when setting up an external time source the documentation was less than clear.  Do you have a good source for the process?

The bios is up to date.

Thanks for your help.
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

George SimosIT Pro Consultant - IT Systems AdministratorCommented:
I was expecting this (domain membership of the Hyper-V) actually and that's the reason I proposed the external time source sync for the hyper-v and for the SBS 2011 which I guess holds the Domain that Hyper-V is a member of and because of its nature (SBS 2011) the PDC role is on it so if Hyper-V is a member and syncs time from the PDC (SBS 2011) but the latter syncs its time from the Hyper-V Integrations then it is one of the problems that will arise if you don't disable the time syncing of the VM DC from the VM Host (Hyper-V).
So my recommendation in this case is that you need to disable the Time Sync from your SBS VM integration settings.

Then Sync SBS's time with one or more external sources as I wrote in my first post and let Hyper-V sync with the PDC (without any configuration), you don't have to use the /register flag.

At least this way you will not have issues and time drifts, however keep in mind that the clock of Hyper-V will need the DC to be up in order to sync and when drift gets detected (between the bios clock and the OS's clock it will try to sync with the PDC to correct it, so it must be always -at least- available-).
Svet PaperovIT ManagerCommented:
All information you need can be found here

Alternatively, you could disable the time synchronization in the Integration Services provided to the domain controller and leave the time keeping job to it. In that case, you have to make sure it's able to synchronise time from external source.
George SimosIT Pro Consultant - IT Systems AdministratorCommented:
@spaperov: That's exactly what I wrote in my first post.
JackAitkenAuthor Commented:
This fixed my problem.  Great examples of how to set the time source.  I disabled the time sync between the host and client servers and set the time source on the hosted SBS server as suggested.

Can't thank you enough for your quick and complete solution!!

Well done.
George SimosIT Pro Consultant - IT Systems AdministratorCommented:
Glad to hear that you were helped!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.