Solved

Advertising route into BGP

Posted on 2013-12-02
12
280 Views
Last Modified: 2013-12-03
Hi

I need to add the public ip range 196.66.168.0/24 to my BGP config on ISP router so range 196.66.168.0/24 is accessible from internet.

Please advise what command must I add to BGP to advertise the range into BGP.
See attached current  BGP config on ISP router
ISP-BGP
0
Comment
Question by:ciscosupp
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 
LVL 46

Assisted Solution

by:Craig Beck
Craig Beck earned 100 total points
ID: 39691128
It looks like you just need...

router bgp 20190
 address-family ipv4
  network 196.66.168.0

Open in new window

0
 

Author Comment

by:ciscosupp
ID: 39691649
thanks i tried routes are not advertised to outside.
Must i also add a prefix list maybe
please advice
0
 
LVL 4

Expert Comment

by:askincakir
ID: 39691864
Hi,
The prefix which you are trying to advertise should also be in your routing table.
Give that prefix to your directly connected interface or just simply write a static route which will appear in your routing table.
For example:
ip route 196.66.168.0 255.255.255.0 null0
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:ciscosupp
ID: 39691885
so when I add

ip prefix-list MY_ROUTES seq 15 permit 196.216.168.0/24

will it also work please advice
0
 

Author Comment

by:ciscosupp
ID: 39691892
hi have a static route pointing to my firewall

ip route 196.66.168.0 255.255.255.0 196.66.168.5
0
 
LVL 4

Expert Comment

by:askincakir
ID: 39691893
No, it is totally different point. Prefix-list is used for limiting the networks which you are going to advertise.
Example:
router bgp1
network 192.168.1.0
network 192.168.2.0
exit
By default both of the routes will be advertised. But you just want to advertise only one of them. Then you need to write a prefix and just give a permit to one of routes.

ip prefix-list YOUR-ROUTES seq 10 permit 192.168.1.0/24
router bgp 1
neighbor 1.1.1.1 prefix-list out YOUR-ROUTES
exit

192.168.2.0 would not be advertised to your bgp neighbor.
0
 

Author Comment

by:ciscosupp
ID: 39691919
okay so what commands must I add now to advertise the new network.
please advice
note there is no interface in the new ip range on route its only on the firewall
0
 
LVL 4

Expert Comment

by:askincakir
ID: 39691929
So,

to which BGP neighbor you want to advertise this ?
neighbor 196.66.7.29
neighbor 196.66.8.29
neighbor 196.66.10.29
0
 

Author Comment

by:ciscosupp
ID: 39691930
neighbor 196.66.10.29
0
 
LVL 4

Expert Comment

by:askincakir
ID: 39691936
ok,
what is the ip address of firewall where you are going to use this subnet ?
0
 

Author Comment

by:ciscosupp
ID: 39691942
router   196.66.6.1 (the one running BGP /ISP router

Firewall 196.66.6.29
0
 
LVL 4

Accepted Solution

by:
askincakir earned 400 total points
ID: 39691951
ok,
configure terminal
ip route 196.66.168.0 255.255.255.0 196.66.6.29

ip prefix-list MY_ROUTES seq 20 permit 196.66.168.0/24

router bgp 20190
 address-family ipv4
 network 196.66.168.0 mask 255.255.255.0
end
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A few months ago I attended the Rocky Mountain IPv6 Summit which was a two-day educational event; it was the 3rd annual conference held here in Denver, Colorado that was held at the Hyatt Regency Denver at the Colorado Convention Center. It was an e…
Understanding FTPS File transfer is a common requirement in most Enterprises. While there are numerous ways to get a file from Point A to Point B over a network, perhaps the most common method still in use is FTP – File Transfer Protocol. FTP is …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question