XXCopy changes DateModified of Source files when using Win7/Netware Server

Running on a Win7 Pro / Netware 6.5 with Novell Win7 Client 2 SP2 / IR5
 
Using a simple XXCOPY  command (Ver 3.21.0b Pro)

xxcopy \\netwareserver\volume\folder\*.* c:\backupOfVolumeFolder\ /s

Causes the LASTMODIFIED time stamps on the SOURCE files to be changed to the current NW server time.

The exact same command line on a WinXP computer works fine - the source files are un-altered.

Can anyone offer any assistance?

Thanks
RGNCMExpertAsked:
Who is Participating?
 
RGNCMExpertAuthor Commented:
Thank you all for the assistance.  We are working fine since the TTA switch was added.

Ken
0
 
deroodeSystems AdministratorCommented:
It seems to me that this isn't as much a Netware problem as a XXCopy problem. Probably the xxcopy program opens the files as R/W instead of ReadOnly. Have you contacted the vendor of this program?

As an alternative, you should consider using  Robocopy.
0
 
RGNCMExpertAuthor Commented:
I have attempted to contact xxcopy but no response... I am guessing he's taking a Thanksgiving break... So I'll cut him a little slack.

But, there are no problems with running the exact same command on an XP system.

My best guess is that there is a difference between the Win7 and WinXP Netware client.

Even my Novell expert is stumped!

I am trying to see if RoboCopy has the same effect.

Thanks

Ken
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
pgm554Commented:
Why are you using that app?

The copy feature built into the NW client is much faster and easier to use.

http://www.novell.com/documentation/windows_client/windows_client_user/data/b7xhrcg.html
0
 
RGNCMExpertAuthor Commented:
If it were just a simple copy, yes.  novell (or any other copy variant) will work.

The example shown is just for simplicity.

My actual usage is surrounded by thousands of lines of code to generate specific parameters and options... But they ALL have the same effect.  Source dates change.


Ken
0
 
deroodeSystems AdministratorCommented:
It seems that the combination of XXcopy opening the source file in a specific way in combination with the Novell client causes this effect.

If Robocopy isn't an option maybe you could try as a workaround to use an account on the source server that only has Read access?
0
 
RGNCMExpertAuthor Commented:
Sort of a solution found... The author of XXCOPY got back with me with the recommendation that I use the /TTA switch which tells XXCOPY NOT to try to keep the LAST ACCESS time stamp.

This seems to prevent it from also mucking with the MODIFIED DATE.

Ken
0
 
RGNCMExpertAuthor Commented:
Problem was solved by author of the original piece of software...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.