Solved

Joomla -- upgrade now or later ?

Posted on 2013-12-03
2
395 Views
Last Modified: 2013-12-17
I currently have both a test and live Joomla 2.5 site at NetSol.com and want to upgrade to NetSol's most current version, Joomla® 3.0.3

According to http://developer.joomla.org/development-status.html Joomla 2.5 SUPPORT ends on 12/31/14.

Questions

 1. Joomla recommends waiting to upgrade until 3.5 is launched
    since they will support it for 27 months after launch, would you agree ?
      ** http://docs.joomla.org/Joomla_3_FAQ#How_long_is_each_Joomla.21_version_supported.3F
      ** if so, I will make sure my existing MODULES/TEMPLATES/etc are valid on 3.5

 2. What "upgrade method" do you recommend ?
      ** http://extensions.joomla.org/extensions/migration-a-conversion/joomla-migration/15609
0
Comment
Question by:finance_teacher
  • 2
2 Comments
 
LVL 9

Accepted Solution

by:
Rowby Goren earned 500 total points
ID: 39692469
Hello

The first thing you need to do is make sure that any 2.5 extensions, plugins and modules have 3.x compatible versions.   Same goes with your template.

How did you originally install Joomla at netsol?  Via a Netsol automatic installation of Joomla?  Or did you upload it.  

I've used SPUgrade and MigrateMe.  I prefer MigrateMe.  It seemed easier.

Also you will want to do an akeeba SP upgrade let us know FIRST because we will have some tips for you.

While Joomla says to wait until 3.5, I must say that 3.2 is really nice!   Great new features, such as content versioning, and, if you have others using the back end, more control of who gets to modify modules.

I am sure others here will have their suggestions and opinions.

Let's see how the discussion goes.

Rowby
0
 
LVL 9

Expert Comment

by:Rowby Goren
ID: 39725258
Hi inance_teacher,

Thanks for the points.  

If you need more help feel free to let us help you.

Rowby
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Drupal 5.x currently does not have a production-ready patch bundle to allow for split read & writes for a MySQL master/slave replication setup. After reading a open discussion/thread on the Drupal site (http://drupal.org/node/147160 (http://drupal.o…
Since I am currently running into this issue right now as I type this, I though I would share my experiences with moving a ModX Revolution site from one server to another.  It is not an easy task, but can be accomplished rather easily. The first …
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.
Need to grow your business through quality cloud solutions? With everything required to build a cloud platform and solution, you may feel like the distance between you and the cloud is quite long. Help is here. Spend some time learning about the Con…

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now