Solved

Debian enabling SSL

Posted on 2013-12-03
16
357 Views
Last Modified: 2013-12-04
Hi All,

I have created a self signed certificate in debian linux using ssl.  I am now trying to get a default-ssl site setup.  Can someone help me out?  I did follow these instructions:  https://wiki.debian.org/Self-Signed_Certificate , but now apache wont start.  

Thanks,

Jackson
0
Comment
Question by:Jack_son_
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
  • 4
16 Comments
 
LVL 19

Expert Comment

by:xterm
ID: 39692700
Take a look in /var/log/(apache2 or httpd)/(error.log or ssl_error.log)

It should tell you what is causing the startup to fail.
0
 
LVL 29

Accepted Solution

by:
Jan Springer earned 250 total points
ID: 39692976
What does "apachectl -t" say?
0
 

Author Comment

by:Jack_son_
ID: 39695913
Here is the error:

apache2: Could not reliably determine the server's fully qualified domain name, using 2001:4802:7801:103:9128:887c:ff20:5e9c for ServerName
Syntax OK
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 29

Expert Comment

by:Jan Springer
ID: 39695942
In your httpd.conf, do you have 'ServerName' specified?
0
 
LVL 19

Assisted Solution

by:xterm
xterm earned 250 total points
ID: 39695970
Okay, so obviously Apache _is_ starting.  You can verify this by doing:

ps ax | grep httpd

Should look something like this if it's started:

[root@host path]# ps ax | grep httpd
 2116 pts/0    S+     0:00 grep httpd
31082 ?        S      0:45 /usr/sbin/httpd
31234 ?        S      0:46 /usr/sbin/httpd
31235 ?        S      0:48 /usr/sbin/httpd
31416 ?        S      0:45 /usr/sbin/httpd
31417 ?        S      0:46 /usr/sbin/httpd
32293 ?        S      0:45 /usr/sbin/httpd
32342 ?        S      0:47 /usr/sbin/httpd
32344 ?        S      0:48 /usr/sbin/httpd


Judging by the entry in your error log though, it looks like it's trying to bind to your systems IPv6 address.  Are you attempting to connect to the server by name in your web browser, or by IP?

Finally, I get the feeling your Apache might be listening on port 80, but maybe you missed something on the SSL set up and it's not listening on 443.  Please do:

netstat -na | grep :443

If it's SSL-enabled, you'll see something like this:

[root@host ~]# netstat -na | grep :443
tcp        0      0 :::443                         0.0.0.0:*                   LISTEN
tcp        0      0 10.10.0.1:443            0.0.0.0:*                   LISTEN
0
 

Author Comment

by:Jack_son_
ID: 39695978
For the first command I see this:

23649 pts/0    S+     0:00 grep httpd

THe second one I don't see anything....


Also right now I am just trying to use it from public ip
0
 
LVL 19

Assisted Solution

by:xterm
xterm earned 250 total points
ID: 39695988
Okay, so apache didn't start - there must be more in your log files that you're not pasting here.  Can you try to restart it and look at the error_log again?
0
 
LVL 29

Expert Comment

by:Jan Springer
ID: 39695998
How are you starting the service?  What do the apache error logs say?
0
 

Author Comment

by:Jack_son_
ID: 39696171
service apache2 restart

I see the same error as above, I think it may be the name in the config file.
0
 
LVL 29

Assisted Solution

by:Jan Springer
Jan Springer earned 250 total points
ID: 39696197
Have you added a 'ServerName' and reran 'apachectl -t' ?
0
 

Author Comment

by:Jack_son_
ID: 39696216
you mean add it in the default-ssl config file?
0
 
LVL 19

Expert Comment

by:xterm
ID: 39696257
No, change ServerName in httpd.conf (it's commented out by default, so remove the # sign) and change it to your own fully qualified domain name of your server (aka 'server.domain.com').

Of course, I don't think this is your issue because you said it was working fine until you added the SSL config.  I believe it's something you did in the SSL setup that is breaking it.
0
 

Author Comment

by:Jack_son_
ID: 39696324
Thanks; i restored the old ssl config file.  Here is the error I see now:

502 Bad Gateway - Response Error, a bad response was received from another proxy server or the destination origin server.
0
 

Author Comment

by:Jack_son_
ID: 39696345
actually fixed the 502 error.  I think the issue is in the ports.conf file.  Right now the first few lines read:

NameVirtualHost *:80
Listen 80

then there is an
<IfModule mod_ssl.c>
which has the Listen 443 within it.

Can someone verify the config for this an the ssl file?
0
 

Author Comment

by:Jack_son_
ID: 39696421
THanks for the help everyone, got both http and https working!
0
 
LVL 19

Expert Comment

by:xterm
ID: 39696520
Good work!
0

Featured Post

Tutorials alone can't teach real engineering

So we built better training tools.

-Hands-on Labs
-Instructor Mentoring
-Scenario-Based Tests
-Dedicated Cloud Servers

All at your fingertips. What are you waiting for?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Fine Tune your automatic Updates for Ubuntu / Debian
This article discusses how to implement server side field validation and display customized error messages to the client.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question