Solved

How do I make Firefox the default browser in Terminal Services 2008

Posted on 2013-12-03
5
3,580 Views
Last Modified: 2013-12-08
Greetings All,

 I've set up a Terminal Services server (Windows Server 2008 Enterprise SP2) and for one particular reason I need to make Firefox the default browser for all users.

I've found an old solution here on EE but no help. Was written for 2003.

as per another suggestion, I've logged in as local admin and used "Default Programs" to set Firefox as default but that didn't affect other user accounts. (Didn't really think that it would)

Does anyone know of a GPO setting or REG hack that will cause Firefox to be the default browser for all users every time they log in? One global setting?

Thanks in advance for any suggestions!

Mike
0
Comment
Question by:1lsutigerfan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 57

Assisted Solution

by:Pete Long
Pete Long earned 250 total points
ID: 39692848
put this in your login script

Option Explicit

'--------------------------------------------
' Force Default Browser
'--------------------------------------------
Dim Shell
Set Shell = CreateObject("wscript.shell")
Shell.Run ("firefox.exe -silent -setDefaultBrowser")
Set Shell = Nothing

Open in new window


PL

Ref
0
 

Author Comment

by:1lsutigerfan
ID: 39692905
Thanks Pete. I don't have a separate login script for TS users at the moment but I can try setting that up.
0
 

Accepted Solution

by:
1lsutigerfan earned 0 total points
ID: 39693012
Thanks Pete.  you set me on the right path; though I couldn't get your script to work properly.

So here's the solution I came up with.

On the Terminal Services Server, I created a separate login script for Term server users only, using the directions here:

http://support.microsoft.com/kb/195461 

Then, I made my login script look like this:

c:
cd\program files (x86)\Mozilla Firefox
Firefox.exe -silent -setDefaultBrowser

Hope this helps others in the future. Thanks again for your help, Pete.
1
 

Author Closing Comment

by:1lsutigerfan
ID: 39704093
I found a workable solution.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 39704507
Glad to help :)
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
On some Windows 7 (SP1) computers, Windows Update becomes super slow even the computer is reasonably fast.  There's one solution that seemed to have worked well for me (after trying a few other suggested solutions).
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question