Solved

Windows 7 sharing issues

Posted on 2013-12-03
9
303 Views
Last Modified: 2013-12-11
I'm about to slit my wrists, well almost ! I,ve been in computing for 30 years and i believe my brain has stagnated to the point that i can't seem to resolve a simple issue HELP !

I have a newly built win 7 64 bit box that one could call a central repository rather than server since it hold all this small office's documents , scanner and printer. When this was on XP there were never any file sharing issues.
A win7 tosh laptop connected via the same netgear router gets a  windows security prompt for username and password the first time that he tries to access the shared folder on the "server". From then on he is fine for a while or until a reboot, when he will have to pass the credentials again.
There is an XP pro laptop as well that doesn't have any problems at all it seems.
Here is the setup and what i've tried.
All machines are in the same workgroup.
Network sharing ( work network) has been set on , so is discovery and password protected is definatley off.
Share with and share have been set correctly and re checked on the folders.
Norton internet security, access control extra had been turned off
Even changed local policy regarding net lan manager to send netlm only.
All without effect.
Help
0
Comment
Question by:oldtighthead
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 25

Assisted Solution

by:Mohammed Khawaja
Mohammed Khawaja earned 150 total points
ID: 39693623
Why don't you map the drives persistently using the credentials.  This way after every reboot you do not have to pass the credentials.  Have you thought about this?  You could map the drives persistently via command prompt as shown below:

net use x: \\computername\sharename /user:username password /persistent:yes (i.e. net use s: \\win7computer\shared-docs /user:user123 Passw0rd123 /persistent:yes)

Just ensure that the password does not contain $
0
 
LVL 95

Accepted Solution

by:
John Hurst earned 350 total points
ID: 39693653
password protected is definitely off.  <--- That is an issue. On Windows 7, that turns Homegroup ON and you do not want that in a mixed OS environment. Turn Password Protect sharing ON and use usernames and passwords on all computers.

On the Windows 7 machine, make usernames that are the usernames of the laptops with the same passwords as the laptops. I do that on my home office Windows 7 desktop and it solves the credentials problem in a different way than the above post.

And of course, all the machine (especially the new Windows 7 machine) are all PRO and not HOME.

Provide sharing on the Windows 7 folders to the usernames you added to the Windows 7 machine.

.... Thinkpads_User
0
 
LVL 14

Expert Comment

by:Ram Balachandran
ID: 39693676
Can you try creating home group in Windows 7
just Start  and type  "home group"

---

Other option would be try turning off Password-protected sharing on the desktop computer and check for the problem. Do this as mentioned below.
 
1.      Open Advanced sharing settings by clicking the  Start button, and then clickingControl Panel. In the search box, type  network, clickNetwork and Sharing Center, and then, in the left pane, click Change advanced sharing settings.
2.      Expand the  Home or Work network profile.
3.      Under Password protected sharing, click Turn off password protected sharing, and then click Save changes.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 95

Expert Comment

by:John Hurst
ID: 39693682
Homegroup will not work with XP, only ALL Windows 7 machines.

.... Thinkpads_User
0
 

Author Comment

by:oldtighthead
ID: 39694263
A little light has come on between my ears with thinkpads_user comment.... turning password protected off turns Homegroup ON that is exactly the kind of booby trap MS likes to set. I found that a homegroup had been activated on the win7 laptop but nobody admitted to having created one.

I'll try tomorrow with the users and report back.

Thanks guys
0
 

Author Comment

by:oldtighthead
ID: 39697261
Decided to try the duplicate users on both machines for the moment. It looks ok and the machine is now being used by the user to check... I'll let you know.. Does it matter whether the win7 machine has password protected sharing on or off    ??   only turned password on on the win 7 laptop so far..
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39697278
As discussed above, no password protection means HomeGroup ON and vice versa. You can try it the way you have it and if it works, great. I always use passwords because it makes life easier overall.

.... Thinkpads_User
0
 

Author Closing Comment

by:oldtighthead
ID: 39711684
Password protection off comment that enables home groups was the key . User working happily for a week now. cheers guys
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39711794
@oldtighthead - Thanks for the update and I was happy to help.
.... Thinkpads._User
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You may have a outside contractor who comes in once a week or seasonal to do some work in your office but you only want to give him access to the programs and files he needs and keep privet all other documents and programs, can you do this on a loca…
On some Windows 7 (SP1) computers, Windows Update becomes super slow even the computer is reasonably fast.  There's one solution that seemed to have worked well for me (after trying a few other suggested solutions).
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question