Solved

Exchange 2010 unable to change receive message size

Posted on 2013-12-03
13
431 Views
Last Modified: 2013-12-21
Hi, I am running a single Exchange 2010 server running on Server 2008 R2.  I have the maximum message size set to 10240 (default) in the EMC: Organization Configuration > Hub Transport > Global Settings > Transport Settings > Properties AND in Server Configuration > Hub Transport > Receive Connectors Properties.  Message size restrictions are not checked at the user level.

Users can receive a 7MB file, but are blocked from receiving an 8MB file.  However, it seems that they are able to send an approximately 10MB file.  I set the receive size to 12800 in the locations specified above, but it seems that nothing has changed.  I must be missing a setting, but where would that be?

When I send an 8MB message, and then look for the delivery report in OWA tracking, this is the error:

This message won't be sent because it's too large.
55 5.2.3 RESOLVER.RST.SendSizeLimit.Org: message too large for this organization
0
Comment
Question by:Stolzman
13 Comments
 
LVL 14

Expert Comment

by:dmwynne
ID: 39693796
In my experience when you change the message size settings it can take up to 2 hours to take effect unless you restart the Exchange SA and Exchange IS services.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39693963
Transport is the usual one that has to be changed.
You should have all three at the same size - Send, Receive and Global.
Also be aware that you get encoding growth, so depending on the attachment type a 10mb limit may mean anything from 7mb up to be blocked. Usual rule is 25% above the desired limit to allow for encoding (as end users don't understand the encoding growth).

Simon.
0
 
LVL 1

Author Comment

by:Stolzman
ID: 39694240
I did change the transport receive size limit, and after I changed them, I rebooted the server, and still no luck.

As I said above, I changed both receive limits from 10240 to 12800 and nothing changed:  I was able to receive 7MB files but not 8MB.  Changing these limits should have changed the size to above 8MB.

Can anyone tell me why changing these parameters has no effect?
0
 
LVL 12

Expert Comment

by:ktaczala
ID: 39694500
check these values in exchange powershell:
get-transportconfig | ft maxsendsize, maxreceivesize
get-receiveconnector | ft name, maxmessagesize
get-sendconnector | ft name, maxmessagesize
get-mailbox |ft Name, Maxsendsize, maxreceivesize

See this link for more information.
http://www.nogeekleftbehind.com/2011/12/09/show-exchange-message-size-limits-in-sbs-20082011/

commands and locations should be the same on your system.
0
 
LVL 1

Author Comment

by:Stolzman
ID: 39696538
Couple of notes on this output:

Receive connectors Client Narada and Mataji are disabled.
User names have been deleted from the mailbox sizes.  The one mailbox that has a defined maximum is the Discovery Search mailbox
________________________________________________________________________________________________

[PS] C:\Windows\system32>get-transportconfig | ft maxsendsize, maxreceivesize

MaxSendSize                                                 MaxReceiveSize
-----------                                                 --------------
10 MB (10,485,760 bytes)                                    12.5 MB (13,107,200 bytes)


[PS] C:\Windows\system32>get-receiveconnector | ft name, maxmessagesize

Name                                                        MaxMessageSize
----                                                        --------------
Client NARADA                                               10 MB (10,485,760 bytes)
Outside Relay Narada                                        12.5 MB (13,107,200 bytes)
Default Relay                                               12.5 MB (13,107,200 bytes)
Mataji                                                      10 MB (10,485,760 bytes)


[PS] C:\Windows\system32>get-sendconnector | ft name, maxmessagesize

Name                                                        MaxMessageSize
----                                                        --------------
ACSR-SMTP                                                   10 MB (10,485,760 bytes)


[PS] C:\Windows\system32>get-mailbox |ft Name, Maxsendsize, maxreceivesize

 MaxSendSize                             MaxReceiveSize
-----------                             --------------
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
100 MB (104,857,600 bytes)              100 MB (104,857,600 bytes)
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
unlimited                               unlimited
0
 
LVL 12

Expert Comment

by:ktaczala
ID: 39696577
Please use the message tracking log to check the message size of the message that has been NDRed before, see if it’s really fewer than 12.5 MB. Sometimes, message conversion could increase the message size by 33%

Try increasing values to 25meg for testing.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 12

Expert Comment

by:ktaczala
ID: 39696588
What mail client are you using?

See this link: http://support.microsoft.com/kb/960775
0
 
LVL 1

Author Comment

by:Stolzman
ID: 39699034
I changed the receive values to 25600 last night and rebooted this morning, and I am still getting the same error message receiving an 8MB file that the email is too large.  Here are my parameters.

And to answer the other question, we are using Outlook 2010 as an email client

________________________________________________________________________________

[PS] C:\Windows\system32>get-transportconfig | ft maxsendsize, maxreceivesize

MaxSendSize                                                 MaxReceiveSize
-----------                                                 --------------
10 MB (10,485,760 bytes)                                    25 MB (26,214,400 bytes)


[PS] C:\Windows\system32>get-receiveconnector | ft name, maxmessagesize

Name                                                        MaxMessageSize
----                                                        --------------
Outside Relay Narada                                        25 MB (26,214,400 bytes)
Default Relay                                               25 MB (26,214,400 bytes)


[PS] C:\Windows\system32>get-sendconnector | ft name, maxmessagesize

Name                                                        MaxMessageSize
----                                                        --------------
ACSR-SMTP                                                   10 MB (10,485,760 bytes)
0
 
LVL 1

Accepted Solution

by:
Stolzman earned 500 total points
ID: 39712877
Nothing worked until I changed the send size to match the receive size, restarted the transport service, and now that the size is set to 25MB, I can send and receive attachments up to about 16-18MB.
0
 
LVL 1

Author Comment

by:Stolzman
ID: 39712996
I've requested that this question be closed as follows:

Accepted answer: 0 points for Stolzman's comment #a39712877

for the following reason:

No one else had a solution.
0
 
LVL 12

Expert Comment

by:ktaczala
ID: 39712997
I believe I did suggest /answer this issue.
by: ktaczala Posted on 2013-12-04 at 14:03:33ID: 39696577

Please use the message tracking log to check the message size of the message that has been NDRed before, see if it’s really fewer than 12.5 MB. Sometimes, message conversion could increase the message size by 33%

Try increasing values to 25meg for testing.
0
 
LVL 1

Author Comment

by:Stolzman
ID: 39716702
I did increase the message receive size to 25MB for testing, but that did not solve my problem.  It wasn't until I changed the send size to 25MB that I was able to receive messages up to 16-18MN.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Utilizing an array to gracefully append to a list of EmailAddresses
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now