Solved

How to Enable MBString on a PHP Installation in IIS7

Posted on 2013-12-03
5
1,640 Views
Last Modified: 2013-12-04
I am attempting to run an application that was created for me in PHP.  When I navigate to the application page, I get the following error:

The PHP must have the mbstring extension enabled. Please contact technical support.

I understand from reading around that mbstring is not enabled by default.  So I went back into the php.ini file and removed the ";" before each line that referred to an mbstring variable.  I restarted the IIS server, but when I run a phpinfo page, I see no reference to mbstring so I am wondering whether or not mbstring is actually enabled.  

Could someone provide further guidance to a very new PHP user?

Thank you in advance.
0
Comment
Question by:mounty95
  • 2
  • 2
5 Comments
 
LVL 108

Accepted Solution

by:
Ray Paseur earned 500 total points
ID: 39694014
0
 

Author Comment

by:mounty95
ID: 39694141
Ray,

I read all of those articles before I posted.  As I stated in my initial post, I thought that I had enabled all of the mbstring variables discussed in the articles that you referenced.  I restarted IIS, but am not getting any further than that.  I am looking for something a little more substantive.  Everything that I read talks about PHP being set up in an Apache environment, so I was hoping for some guidance towards how IIS might be misconfigured.

I made sure that the dll for mbstring is in the ext directory.  I made sure to comment out all of the mbstring variables in php.ini.  What else could I be missing?  I don't see mbstring referenced in the phpinfo page that I created to test.  Is there something else within IIS that I have to do?  Something more with mappings or anything?
0
 

Author Closing Comment

by:mounty95
ID: 39696786
Being very unfamiliar with PHP and the whole php.ini file configuration and being focused on the mbstring variables I did not know that this file would also effect where PHP looked for the extensions.

Basically, I first missed the:  extension_dir="ext" which was commented out.  I have to hand it to the developers of PHP, they sure locked the configuration down initially when installing.

I then had to ensure that the:  extension=msql.dll was uncommented for MS SQL Server and that all of those settings were enabled as well.
0
 
LVL 108

Expert Comment

by:Ray Paseur
ID: 39696798
Thanks for the points -- PHP has too many configuration variables!

Best regards, ~Ray
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Foreword (July, 2015) Since I first wrote this article, years ago, a great many more people have begun using the internet.  They are coming online from every part of the globe, learning, reading, shopping and spending money at an ever-increasing ra…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now