Solved

Caps Lock issue in Remote Desktop Services running Windows Server 2012 Standard

Posted on 2013-12-03
24
2,718 Views
Last Modified: 2016-06-27
Scenario:

User is logged into Remote Desktop Services running on virtualised (VMWare esxi) Windows Server 2012 Standard. They could be typing something into a dialog box and it starts out in lowercase and then suddenly the caps lock key activates and it starts displaying the typed letters in uppercase. The caps lock light indicator on the keyboard remains off. Press the caps lock key and the light indicator turns on and the typed text is in lowercase. Minimise the RDP screen to taskbar and maximise the screen "corrects" the state of the caps lock.

This issue happens intermittently I have multiple users that have experienced this problem, but for one user it happens on a regular occurance (at least half a dozen or more times a day).

Things tried:

Changing computer, keyboard and mouse. Changing operating systems (happens with both Windows 7 and XP). Updating RDP client under both operating systems. All the research that I've done relates to either Windows 2000 or Windows 2003 operating systems.

Any suggestions?
0
Comment
Question by:Peak-Support
  • 12
  • 4
  • 3
  • +4
24 Comments
 
LVL 6

Expert Comment

by:donnk
ID: 39694944
try tapping shift twice
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 39697066
@donnk: Tried that and it made no difference.
0
 

Expert Comment

by:Datamex_Helpdesk
ID: 40050281
Hey Peak-Support,

Do u have solved the problem?
I have a customer with exact the same problem as u described. They have also VMWare on ESXi and a RDS Server 2012R2. Our costumer has also RES Workspace Manager. (http://www.ressoftware.com/uk/product/res-workspace-manager)

Here is what we did:
- changed Thin client to PC --> same problem
- Different Keyboard --> Same problem
- More than one user with the same problem

Searching on Google have showed us that the problem could be in VMWare, in RES of in Windows.

Today we found an article witch may solve the problem by removing the keyboard layout. We created an IgnoreRemoteKeyboardLayout DWORD in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout and setting it to 1.  We will wait a couple days to see if this is the problem.
If not, and u having stile the same problem, then we will contact Microsoft.

So I hope u have found a solution!
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40052584
No. l have not found a solution to this issue. I have not tried that Keyboard Layout you have suggested - let me know if it works for you!

What ESXi version do you have? I'm tempted to either upgrade to 5.5 or move to Microsoft Hyper-V.
0
 

Expert Comment

by:Datamex_Helpdesk
ID: 40085689
The Keyboard Layout does not work. I have contacted MS support and opened a Case.
At this moment we are troubleshooting whit the MS support team. I will update u when we found a solution.  
But it could take a wile..

I don’t think the problem is in ESXi, we have many customers with ESX and Hyper-V and no othher custumer has this problem. I Found an KB article with almost the same problem. Different is that de KB was for an Japanese Keyboard.
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40090020
Thanks for the update. Interested to see what Microsoft has to say!
0
 

Expert Comment

by:Supportoslo
ID: 40092744
Hi, is this problem coincidentally on a Vmware host whereas the VM for the terminal server is a version 10 VM (on the vm hardware level)?

I am having the exact same problem with a 2012R2 server on 5.5 Vmware platform, and this is the only mismatch I can see from other VM's (the version 10 hardware level)
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40094321
Hi,
My VM version that I have the problem on is version 8.

The reason I think I get it happening with one specific user significantly more than everybody else is because that user uses the caps lock key like the shift key. So types the sentenace:
<caps lock>I<caps lock> saw that <caps lock>F<capslock>rank gave his dog <caps lock>R<caps lock>alph some food.
0
 

Expert Comment

by:Supportoslo
ID: 40094870
Hah, that sounds unpractical... Could be that in your case...
Not so sure in my case as it happens very randomly on many users.
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40097122
I get it happening randomly for other users too.. I just get it happening several times a day with that one particular user.
0
 

Expert Comment

by:Datamex_Helpdesk
ID: 40171689
We have an answer from MS support:


ISSUE: In RDP session, intermittently "Caps Lock" would turn on for users. When it turns ON, the cap locks light stays off on the keyboard.
 
CAUSE: Still Unknown.
 
RESOLUTION: No known solution as of now, we have the product group team to be finding a fix for this issue.
 

Please note: As we didn’t deliver you a resolution, we have marked this incident as ‘non-decrement’ for you. Hence, this incident is being closed as a free case.
 
But doing so, if would like to revisit this incident in future. We will have to request for a new incident as this one has been refunded. We will then be glad to continue working with you.
 

Please remind that there more problems with keyboard and RDP session!
0
 

Expert Comment

by:Supportoslo
ID: 40171740
I found a solution and the root cause for the users in my case...
In Office applications like Word, there is a "Auto correct the accidental use of cAPS LOCK" feature.
This autocorrects misuse of Caps lock in Word/Outlook etc, but the problem happened when Outlook/Word did this, and the light on the users keyboard did not sync with it! So the caps lock light stayed on, but caps lock was turned off. This makes the caps lock function and caps lock light to completely fall out of sync.

http://office.microsoft.com/en-us/word-help/automatically-correct-capitalization-HA010174730.aspx

I have not heard any complaints from the user after disabling this feature in Office.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Author Comment

by:Peak-Support
ID: 40173441
@Datamex Helpdesk - that sucks that they haven't found a solution yet.

@Supportosio - That's very interesting. For me, the problem happens when they are typing within a non-microsoft application. However they do have office programs, such as Outlook, open in the background so it may still be affecting it. Unfortunately the specific user that this was happening for is now accessing the system differently and I cannot test with that user.

Summary: I want to leave this case open as we will be reconfiguring our system as soon as the internet connection at one of our sites is upgraded and this problem is going to return.
0
 

Expert Comment

by:Datamex_Helpdesk
ID: 40173952
@Peak-Support,

I know! MS has recognized the problem. They have now several cases in investigation. I will get an message from MS team when the fix is ready. I will try to remember when we have a fix to post an massage. According to develop team they expect to have a pre-fix in upcoming weeks.

We have also this problem in non-MS applications. But as I mentioned before, the problem exists in several scenario's as MS told me.
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40179444
@Datamex - I look forward to Microsoft's response
0
 
LVL 2

Expert Comment

by:kibatsu
ID: 40405515
Has there been any further updates from Microsoft on this issue yet?
I am also seeing this issue with a client running Server 2012 R2 RDP (running on XenServer 6.2) and Dell WYSE T10 Thin Clients.
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40405603
Not as far as I know. I sent Datamex a private message on Experts Exchange last week asking if he had an update. No response yet.
0
 

Expert Comment

by:Kentad
ID: 40566143
I have the exact same issue. Windows Server 2012R2 Terminal server on the metal. I kind of have a workaround for it, if you minimize the session, tap caps lock on and off, then maximize the session the problem goes away, unfortunately I'm not so sure thin clients will have the same luck. Interesting that MS hasn't solved this yet.
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 40571445
Hi Kentad,
The problem I have is that the users look at their keyboard rather than their screen and can type quite an amount of text before they realise the problem has happened.

I've all but given up that Microsoft will fix this issue.

Thanks.
0
 
LVL 1

Expert Comment

by:Member_2_7965653
ID: 41665083
Guys,

Beliave or not, i found a way to get this resolved.

It is "quickfix" but better than lost the job lol !!!

http://www.georgejopling.co.uk/capslock/capslock.html

I just installed it at my all thinclients and worked. Its gave a hard and stupied job, but Microsoft dont care about us

Enjoy !!

fernandobsantos@gmail.com
0
 
LVL 1

Author Comment

by:Peak-Support
ID: 41665725
How is this a solution? Correct me if I'm wrong but this only gives us a software indication of what state the caps lock is in. It does not fix the fact that the state between the machine and keyboard is inverted..
0
 
LVL 1

Assisted Solution

by:Member_2_7965653
Member_2_7965653 earned 500 total points
ID: 41667118
Its synced with my rdp session, when you keep nunlock activated inside the application. Did you tried?

like i said, it is a QuickFix, at now i dont have more lot of users calling to mu desk and complain lol

You can try this (ifound at other forum), works as well...

There is a known issue with numlock getting out of sync on RDP sessions to Windows 2008 servers.
http://support.microsoft.com/kb/958503

The values supported by [HKEY_CURRENT_USER \ Control Panel \ Keyboard]
 InitialKeyboardIndicators  are as follows:

 "0" - All Keys off
 "1" - Caps Lock on
 "2" - Num Lock on
 "4" - Scroll Lock on

 For multiple keys, add their values:
 "3" - Caps Lock and Num Lock on
 "5" - Caps Lock and Scroll Lock on
 "6" - Num Lock and Scroll Lock on
 "7" - Caps Lock, Num Lock, and Scroll Lock on

The default value in Windows 2008 is "2147483648"
This tells the OS to honour the settings from the BIOS.
So if your BIOS is set for NUMLOCK Off then that is what your users will get whenever they logon to the server...irrespective of how their last sessions was configured.

Apparently you need to set the value in HEX so to enable numlock  with option "2" you need to entered as "80000002"
0
 
LVL 1

Accepted Solution

by:
Peak-Support earned 0 total points
ID: 41668135
I can't test it as the environment no longer exists. I didn't realise this question was still open to be honest. Also this issue was about caps lock not numlock. I'm going to award you as assisted solution in the hopes that somebody else finds this useful.
0
 
LVL 1

Author Closing Comment

by:Peak-Support
ID: 41676389
Environment no longer exists and cannot be tested.
0

Featured Post

Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

Join & Write a Comment

I don't know if many of you have made the great mistake of using the Cisco Thin Client model with the management software VXC. If you have then you are probably more then familiar with the incredibly clunky interface, the numerous work arounds, and …
What to do when Windows Update is not working correctly? What tools can I use to detect the cause of the malfunction problem? What does this numeric error code mean? These and other questions that you have been asking in the past are answered here (…
In this Micro Tutorial viewers will learn how they can get their files copied out from their unbootable system without need to use recovery services. As an example non-bootable Windows 2012R2 installation is used which has boot problems.
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now