Solved

Uplinking a Cisco 3560 Switch

Posted on 2013-12-04
11
515 Views
Last Modified: 2013-12-04
I am fairly new to switching so I am just doing this in a test environment to teach myself some things. I am trying to uplink a cisco 3560 switch from another 3560 switch. I have it linked and I can plug in a laptop to the switch and get out to the internet but I am unable to ping the switch, telnet, or ping from the switch. It shows that VLAN2 is down but I am not sure why. I have VLAN1 administratively down and should be using VLAN2. What am I missing with the setup? Please let me know what other configurations you need.

The uplink port is configured like this:

 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 queue-set 2
 mls qos trust cos
 auto qos voip trust


The port that it is being uplinked from is configured like this:
 
 switchport trunk encapsulation dot1q
 switchport mode trunk

Thank you!
0
Comment
Question by:Winsoup
  • 6
  • 5
11 Comments
 
LVL 12

Expert Comment

by:Infamus
ID: 39696761
Did you setup VTP on the main switch?

The main switch should be the VTP server and the second switch should be the VTP client.

If they are on VTP transparent mode, then you need the same VLANs on each switch.

sh vtp status will tell you.
0
 
LVL 3

Author Comment

by:Winsoup
ID: 39696780
Yes.
0
 
LVL 12

Expert Comment

by:Infamus
ID: 39696795
can you post "sh run"?
0
 
LVL 3

Author Comment

by:Winsoup
ID: 39696844
CORP_IDF_SPARE3#sh run
Building configuration...

Current configuration : 6252 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CORP_IDF_SPARE3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$02gN$jgoEEPcpWNw4jDqU67VKX/
enable password
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip name-server 10.10.4.56
ip name-server 10.10.4.57
!
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint TP-self-signed-1932881024
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1932881024
 revocation-check none
 rsakeypair TP-self-signed-1932881024
!
!
crypto pki certificate chain TP-self-signed-1932881024
 certificate self-signed 01
  30820248 308201B1 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31393332 38383130 3234301E 170D3933 30333031 30303031
  31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 39333238
  38313032 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CB2F 7216007F BC77CF7B 878982F3 D83C699F 6AB94482 AC1D56FF CF8ED65B
  0BCBEE73 A053EAD8 CB74944F C5E38DF1 B4582F6A D292F33D 1A2CB7C9 4DB7D530
  6ACD1CCC 69C507DB E102F181 AFC02CEE 6A79497C 4836AFC1 AFA51824 F9BD5809
  74863C3E D61A23D4 C70DA069 530948B0 97AECF7E F4D75D39 FE9744C7 FE0C7131
  99CB0203 010001A3 70306E30 0F060355 1D130101 FF040530 030101FF 301B0603
  551D1104 14301282 10434F52 505F4944 465F5350 41524533 2E301F06 03551D23
  04183016 80148B00 6F295D36 A196DB6D 6E3E4E6E 1A54F82F 0EF7301D 0603551D
  0E041604 148B006F 295D36A1 96DB6D6E 3E4E6E1A 54F82F0E F7300D06 092A8648
  86F70D01 01040500 03818100 570B953D 5E41D1C4 1102860B B3E8E100 D0FCEDB0
  C0D04BD6 F1C83005 57524628 6AF7054A 8BD4C854 F52C6554 39BA94A6 DA4EC2AD
  9BA393A8 212ED02B F8DFACE0 B989E929 5D3AD5A3 D20D496E 40CE8D89 B5FCEBA0
  8B19F0F3 298A99C6 550C5C10 D1F18C94 AFDCA895 A5B49456 24B4024F C2074FCA
  D89E396A 7D829C6D EC3C62BA
  quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 mls qos trust dscp
 spanning-tree portfast
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Vlan2
 ip address 10.10.2.29 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
ip default-gateway 10.10.2.1
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password
 login
 length 0
line vty 5 15
 password
 login
 length 0
!
end

CORP_IDF_SPARE3#
0
 
LVL 12

Expert Comment

by:Infamus
ID: 39696868
According to your output, you are uplinking this interface :

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 queue-set 2
 mls qos trust cos
 auto qos voip trust

The interface on the other should be configured the same as well.

Can you also do "sh vtp status" from both switches and also "sh vlan brief" from both switches?

You also need to assign any interface to vlan 2 in order to bring the vlan up.

interface fa0/10
switchport access vlan 2
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 3

Author Comment

by:Winsoup
ID: 39696896
Main Switch

sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 25
VTP Operating Mode              : Server
VTP Domain Name                 : domain.local
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x62 0x62 0x7B 0xFD 0x96 0x27 0x8E 0xC4
Configuration last modified by 10.11.254.251 at 11-28-11 17:57:44
Local updater ID is 10.10.2.27 on interface Vl2 (lowest numbered VLAN interface found)



Switch Being Uplinked


CORP_IDF_SPARE3#sh vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 7
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 6
VTP Operating Mode              : Client
VTP Domain Name                 : domain.local
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x4D 0xD7 0x7F 0xBB 0xCD 0x75 0xD0 0x65
Configuration last modified by 0.0.0.0 at 3-1-93 00:06:08


Main Switch


CORP__IDF_SPARE#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Gi0/1, Gi0/2
2    Management_VLAN                  active
4    Server_VLAN                      active
5    RIS_VLAN                         active    Fa0/1
10   VLAN0010                         active
20   Corp_VoIP_VLAN                   active
21   Corp_Office_VLAN                 active
22   Apple-Corp                       active
24   corp_wireless                    active
30   DC_VoIP_VLAN                     active
31   DC_Office_VLAN                   active
32   DC_Factory_VLAN                  active
40   East_VoIP_VLAN                   active
41   East_Office_VLAN                 active
42   East_Factory_VLAN                active
 --More--

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
50   West_VoIP_VLAN                   active
51   West_Office_VLAN                 active
52   West_Factory_VLAN                active
60   vmware                           active
70   VLAN0070                         active
71   VLAN0071                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
CORP__IDF_SPARE#



Switch Being Uplinked


CORP_IDF_SPARE3#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/2
5    VLAN0005                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
CORP_IDF_SPARE3#
0
 
LVL 12

Expert Comment

by:Infamus
ID: 39696911
I would change the spare switch VTP to transparent and make it to client again mainly because it has higher revision number.

You should run "sh vtp password" to make sure you have set the same password on the spare switch.

Also change the VTP version to 2 on the spare switch.
0
 
LVL 3

Author Comment

by:Winsoup
ID: 39696931
I have them both named as spare switches for testing. Can you specify which one you're referring to.

The switch I am trying to uplink is spare3 and the main switch is just spare.
0
 
LVL 12

Accepted Solution

by:
Infamus earned 500 total points
ID: 39696956
Sorry, I meant to say spare3.

Only do "sh vtp password" on the main switch to see if there's any password setup.
0
 
LVL 3

Author Comment

by:Winsoup
ID: 39696968
No worries.
You da man, there was a password set on the main switch but not on the other one. As soon as I changed it then vlan2 came up and I was able to ping to and from the switch.

Thank you very much.
0
 
LVL 12

Expert Comment

by:Infamus
ID: 39696973
Glad it worked out.
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

If you’re like me and you like peace and quiet, saving money, and pretty lights, then this article is for you. For financial reasons, I buy all the Cisco equipment for my home lab second-hand. The first thing to wear out is usually one of the coo…
Hello All, I have been training on Multicast for a while now and whenever I start the topic , I find out that my friends /  Colleagues mention that they do not know how to test Multicast Joins. As most of the multicast would be video traffic and …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now