Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1770
  • Last Modified:

Windows update options grayed out in Computer Properties

Can not change the windows update option by right clicking on My Computer the option is grayed out. Using Windows 8 R2 virtual server
0
Ron-mds
Asked:
Ron-mds
  • 2
1 Solution
 
BlueYonderCommented:
check these three registry values and make sure they do not exist, or if they do, they are disabled (set to False):
HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate - DisableWindowsUpdateAccess
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer - NoWindowsUpdate
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate - DisableWindowsUpdateAccess
If all three registry values are absent, then your problem is not policy-based; skip to the last paragraph.
If one of those values does exist then you've not identified the correct policy object, or have looked in the wrong places of the policy object for the settings to disable.
The first is in Computer Configuration\System\Internet Communication Management\Internet Communication Settings and is called Turn off access to all Windows Update features.
The second is in User Configuration\Administrative Templates\Start Menu and Taskbar and is called Remove links and access to Windows Update.
The third is in User Configuration\Administrative Templates\Windows Components\Windows Update and is called Remove access to use all Windows Update features.
If identifying the GPO with these settings is not easily done, then another option for troubleshooting purposes is to create a new OU where there are =NO= policies linked, and then you only need to troubleshoot the Default Domain Policy. Put ONE system in that OU to use as your test system. Do a GPUPDATE and see if the Default Domain Policy is the culprit. If not, then add one policy back, at a time, which can help to identify the policy that may be causing the issue.
If the registry values are not present, then as noted this is not a policy-based issue. From the server's Administrator account on the Windows Server 2008 system go to Control Panel | Windows Update | Change Settings. In Change Settings observe whether the option Allow all users to install updates on this computer option is checked or unchecked. If it unchecked, then you've likely identified your cause.
0
 
Ron-mdsAuthor Commented:
The registry keys do not exist and Allow all users to install update is checked, however the option to change "install updates automatically" is still grayed out and cannot be changed
0
 
Ron-mdsAuthor Commented:
This is a virtual windows 2008 R2 server, perhaps that changes how thing are done
0
 
Santosh GuptaCommented:
run the RSOP.msc and see if some policy is applied.

if not then copy the registry setting for windows update from same os other system and merge it.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now