Solved

Distribution list missing from Exchange 2007 server, wasn't delete, can't re-add, says name is in use

Posted on 2013-12-04
3
467 Views
Last Modified: 2013-12-05
Users complained the couldn't email a security group that'd been mail enabled.  They saw the following:

The recipient's e-mail address was not found in the recipient's e-mail system. Microsoft Exchange will not try to redeliver this message for you. Please check the e-mail address and try resending this message, or provide the following diagnostic text to your system administrator.

I checked AD and the group is still there, but it's missing from Exchange and no one's deleted it.  I tried to create a new one with the same one and got this:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00


International Group
Failed

Error:
The value "______" of property "SamAccountName" is used by another recipient object "domain/domains Groups/Group name". Please specify another value.

Exchange Management Shell command attempted:
new-DistributionGroup -Name 'International Group' -Type 'Security' -OrganizationalUnit 'domain/Users' -SamAccountName 'International Group' -Alias 'InternationalGroup'

Elapsed Time: 00:00:00

So somehow it's missing from exchange while still being in AD and it won't let me re-create it.  Using a different name is problematic.  Any ideas?  THanks.
0
Comment
Question by:LB1234
  • 2
3 Comments
 
LVL 19

Accepted Solution

by:
Adam Farage earned 500 total points
ID: 39697424
I would need more information on the group to answer the question of "why" this occurred, but try this out:


- Open AD Users and Computers and search for the group.
- Open the Security Distribution Group and make sure it is setup as a Universal Security Group. That is one reason why this might not be working.
- Allow AD replication to occur, and then attempt to search for the group within Exchange Management Console (you can use the shell, but the graphical interface is a bit easier for this task).
- Open the group and see if it has any exchange attributes assigned to itself (e.g: SMTP address). If not, simply mail enable it within the Exchange Management Console.

To my understanding in Exchange 2007-2010 you can only mail enable a security group as long as it is universal. Furthermore, you cannot have two groups with the same SAM account name within AD, so the only other solution to get this group back (with the same SMTP settings) is to simply mail enable the universal security group.
0
 
LVL 1

Author Closing Comment

by:LB1234
ID: 39698021
Thanks a lot! That worked!
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 39699224
No problem - enjoy :D
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Read this checklist to learn more about the 15 things you should never include in an email signature.
This article explains the steps required to use the default Photos screensaver to display branding/corporate images
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question