Solved

Connecting to SQL Server database in Codecharge studio

Posted on 2013-12-05
4
952 Views
Last Modified: 2013-12-12
Hi,

I'm trying to connect to a database in Microsoft SQl server 2012 in Windows_NT mode.

The database name is "Checkweigher" and is setup in mixed mode.

I''ve setup the Codecharge studio connection.

Database: SQL Server
Server Name: ***\MES
Selected use Windows NT Integrated security
And selected the database.

I tested the connection and it says that the connection was successful

 But when I click on the "Live Page: tab, I get the following error:

Unable to establish connection to database.
Error information:
Microsoft OLE DB Provider for SQL Server (0x80004005)
Cannot open database "CheckWeighers" requested by the login. The login failed.
Other possible cause of this problem:
The database cannot be opened, most likely due to incorrect connection settings or insufficient security set on your database folder or file.
For more details please refer to http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306518

I just can't seem to find a solution. Please help.

Thanks.
0
Comment
Question by:Buddhi_imatrix
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 33

Expert Comment

by:Big Monty
ID: 39703619
usually when you get this message, it's due to the connecting user not having enough rights to the database. Are you sure you're using the same user as when you initially tested the connection?

it may also be trying to connect via your IIS user (I've run into setups like these), try giving your IIS user full rights (just as a test) and see if that helps.
0
 
LVL 29

Accepted Solution

by:
sammySeltzer earned 500 total points
ID: 39713125
Yes, The_Big_Daddy is correct.

Open SQL Server Management Studio (SSMS),
Right-click on the database in question
Click on Properties
Click on Permissions
Then if you don't see the user there, click Add
Click Browse
Look for the login name you created
Finally, check Execute.

If the login isn't already created, then create it first.
0
 

Author Comment

by:Buddhi_imatrix
ID: 39715541
Thanks guys!!... i tried to pin point the problem so i deleted all the permission I had given it but it still works. Seems a bit weird.
0
 
LVL 33

Expert Comment

by:Big Monty
ID: 39715562
No split in the points? I provided the overall theory in the answer and SS provided the fix. Not sure how you came about your awarding of points on this one....
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently decide that I needed a way to make my pages scream on the net.   While searching around how I can accomplish this I stumbled across a great article that stated "minimize the server requests." I got to thinking, hey, I use more than one…
I was asked about the differences between classic ASP and ASP.NET, so let me put them down here, for reference: Let's make the introductions... Classic ASP was launched by Microsoft in 1998 and dynamically generate web pages upon user interact…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question