ALL long queries on localhost

Large query

Error Code: 2013. Lost connection to MySQL server during query
600.510 sec


I am using mysql on windows on localhost
using mysql workbench query editor

how can I extend query timeout

I do not wish to modify current query because
I am looking for an answer for all queries.
LVL 1
rgb192Asked:
Who is Participating?
 
ZberteocConnect With a Mentor Commented:
I think you can modify the timeout even in UI in the Global Variables. I am not sure where you can find it in Workbench, try:

Edit->Preferences->SQL Editor tab
0
 
COBOLdinosaurCommented:
Set net_read_timeout to higher value the current 600 seconds is a common setting, but if you need more then just increase it in the my.ini file.  You can probably also do it through the workbench, but I don't use the workbench, and I don't know the specific method of doing that.


Cd&
0
 
rgb192Author Commented:
Where would i find my.ini? I do not know what folder i installed mysql or which mysql (i have zend and wamp ) that i am accessing using workbench
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
rgb192Author Commented:
Finding my.ini is a related question

http://www.experts-exchange.com/Database/MySQL/Q_28312933.html

So once I find my.ini, I can respond to this question.
0
 
Ray PaseurCommented:
A query that runs for 600 seconds might have something wrong.  EXPLAIN SELECT might give you a hint about what MySQL is doing with its time.  See also this article:
http://www.experts-exchange.com/Database/MySQL/A_1250-3-Ways-to-Speed-Up-MySQL.html
0
 
COBOLdinosaurCommented:
If you have wampserver installed, there should be an icon on the taskbar click it and select my.ini and it will open the ini in notepad.


Cd&
0
 
rgb192Author Commented:
note: this is xampp and not wamp.
C:\xampp\ does not exist in windows explorer (even with show hidden files and folders).
I have zend php framework, xampp, wamp installed

what is the option I change
0
 
rgb192Author Commented:
This is the correct answer extending the query timeout time.  I will keep on extending because there could be an error with the query but I know that I can eliminate all timeout times. Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.