Solved

#DELETE in all fields of All rows in linked SQL Server table

Posted on 2013-12-09
4
5,476 Views
Last Modified: 2013-12-09
Been migrating some Access data to SQL Server lately.   Experienced a previously unencountered experience this morning.

Opened a table in Access that contained #DELETED in every field and every row of a linked SQL Server table.  Went to SQL Server, and all of the data I imported to the table yesterday is there.  Went back to Access, deleted the linked table, performed a Compact and Repair, closed the database, opened the db, relinked the SQL Server table and still have the same problem.

all of the other tables linked to that SQL Server are working correctly, and the one that is experiencing a problem only has about 2000 records.

Any ideas?
0
Comment
Question by:Dale Fye (Access MVP)
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 58

Accepted Solution

by:
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 39706226
Dale,

Try adding a TimeStamp column to the table.  As for why, take a look at these two MSKB articles:

PRB: Explaining "Record is deleted" error accessing ODBC table
http://support.microsoft.com/kb/172339

"#Deleted" errors with linked ODBC tables
http://support.microsoft.com/kb/128809

which explains why this occurs and things you can do to avoid the problem.

Jim.
0
 
LVL 58
ID: 39706240
There's also a work around where you can define an index on the Access side if there is no unique index on the SQL side.

Optimizing Microsoft Office Access Applications Linked to SQL Server
http://msdn.microsoft.com/en-us/library/bb188204.aspx

See the section "Adjusting Dynaset Behavior"

Jim.
0
 
LVL 48

Author Closing Comment

by:Dale Fye (Access MVP)
ID: 39706341
Jim,

Thanks.  The table already had a unique ID field that was defined as the primary key, and a timestamp field.

However, after reading the references, I went back to the table design and realized that the ID field was a bigint, not an integer.  I believe that was the problem as the new table using int instead of bigint is working properly.

Dale
0
 
LVL 58
ID: 39706411
That will do it!

Jim.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
Traditionally, the method to display pictures in Access forms and reports is to first download them from URLs to a folder, record the path in a table and then let the form or report pull the pictures from that folder. But why not let Windows retr…
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…
With Microsoft Access, learn how to start a database in different ways and produce different start-up actions allowing you to use a single database to perform multiple tasks. Specify a start-up form through options: Specify an Autoexec macro: Us…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question