?
Solved

xmanager : Acess to server's GUI

Posted on 2013-12-09
6
Medium Priority
?
1,295 Views
Last Modified: 2014-01-21
Hello experts,

I have a centos server.

I use the command line interface with the application Xmanager (xterm).

However,  I want to access  the gui interface, but I can not. Please help
0
Comment
Question by:cismoney
  • 2
  • 2
  • 2
6 Comments
 
LVL 19

Expert Comment

by:xterm
ID: 39706835
You can install x11vnc (yum install x11vnc) on the CentOS server which will attach to the running xorg process, and then you can use regular VNC viewer to connect to the GUI.
0
 
LVL 19

Assisted Solution

by:xterm
xterm earned 668 total points
ID: 39706840
After you've installed x11vnc, start it up something like this:

x11vnc -nodpms -rfbauth -xkb /home/your_username/.vnc/passwd -display :0

You will have to create that password file with the 'vncpasswd' command.

Then just connect to the CentOS server via VNC.  Make sure port 5900 is open in iptables.
0
 
LVL 31

Expert Comment

by:serialband
ID: 39710460
VNC is unencrypted.  If you're not on a trusted local network, then you should either tunnel VNC over ssh or use a VPN.  You could also install NoMachine server on the CentOS system and use a NoMachine client.  There's an open sourced version of NoMachine.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
LVL 62

Assisted Solution

by:gheist
gheist earned 664 total points
ID: 39732200
Xming + putty works very well
you need to install xauth on server and enable X11 forwarding in putty
then having Xming running rest just happens magically
0
 
LVL 31

Accepted Solution

by:
serialband earned 668 total points
ID: 39732392
Ok, I've read up on Xmanager and it seems that you can tunnel it over ssh.  If you are using it over ssh, this would suggest that you need to enable X11 over ssh as gheist suggested.  In that case, you'd need to edit /etc/ssh/sshd_config and find the commented line

#X11Forwarding no

and uncomment it and change the no to a yes

X11Forwarding yes

If that's not the case, please provide more detail on how you connect to your server.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39732871
X11forwarding is on by default on centos
xauth package is missing thing...
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month16 days, 15 hours left to enroll

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question