Solved

Buttons won't work in Access 2013

Posted on 2013-12-09
4
3,038 Views
Last Modified: 2013-12-09
I have an Access db that was working correctly in Access 2010.  When I try and run it on a machine with Access 2013 the buttons will not navigate through the interface.

Using the Navigation Pane I can open tables and view data. I can run queries.  I can manually open forms and reports.  But none of my buttons respond when clicked.

I don't know of if it is related, but when I first opened in Access 2013 I had some missing references which I cleared.  I then compiled with no errors. Not sure if my problem is related to the issue I was having with the references or not.

Thanks in advance for your help.
0
Comment
Question by:Jinghui Li
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 58

Accepted Solution

by:
Jim Dettman (Microsoft MVP/ EE MVE) earned 500 total points
ID: 39707243
No, what your missing is that the DB is no longer in a trusted location.

If it's not in a trusted location, then it should be asking you to enable the content when you start it.

Unless you answer yes, all marco's and code will not work.

The other option is to add its current location as a trusted location (Office button, options, trust center).

Jim.
0
 

Author Comment

by:Jinghui Li
ID: 39707247
Oddly, it is not prompting me to enable content as I was accustomed to it doing in Access 2010 - unless it's in a different place and I am missing it.  

Also, I had previously checked the box to enable our network as a trusted location but that didn't help.
0
 
LVL 58
ID: 39707260
I don't have 2013 loaded at the moment, but I'm sure that's the problem.

Look under the trust settings for message bar and see what it's set to.

By the way, is this DB in the same place as the old one or no?

Jim.
0
 

Author Comment

by:Jinghui Li
ID: 39707269
YEP!  You are right!

I had thought that checking the box to "allow trusted locations on my network" would have done the trick.  But I had to actually add our network path as a trusted location.

Thanks for putting me on the right path!  I appreciate your quick help.
0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In earlier versions of Windows (XP and before), you could drag a database to the taskbar, where it would appear as a taskbar icon to open that database.  This article shows how to recreate this functionality in Windows 7 through 10.
Access developers frequently have requirements to interact with Excel (import from or output to) in their applications.  You might be able to accomplish this with the TransferSpreadsheet and OutputTo methods, but in this series of articles I will di…
With Microsoft Access, learn how to start a database in different ways and produce different start-up actions allowing you to use a single database to perform multiple tasks. Specify a start-up form through options: Specify an Autoexec macro: Us…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question