[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

TMG 2010 asks for credentials twice in OWA

Posted on 2013-12-10
5
Medium Priority
?
1,342 Views
Last Modified: 2013-12-15
Hi all!

I have replaced the old TMG 2010 server with a new one, and now Activesync doesn't work and OWA asks for credentials twice before letting me in.

I have checked that there is only basic and windows integrated authentication on the Exchange server, and forms based on the TMG.

There were some trouble with the certificates, and I had to re-key them, this is maybe some of the problem...

Thanks!
0
Comment
Question by:Sekodata
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 16

Expert Comment

by:Dirk Mare
ID: 39707965
What does test exchange connectivity tell you?

https://testconnectivity.microsoft.com/

DirkMare
0
 

Author Comment

by:Sekodata
ID: 39707993
Yes, get an error here. But I have tested some more and I see that it works for another domain that is configured on the same TMG and the same Exchange server. The only difference is the certificate. It seems that there is a connection problem/trust between the two servers regarding the new certificate
0
 
LVL 16

Expert Comment

by:Dirk Mare
ID: 39708002
Did you move all the certificates to the new box from the old one.

It could also be something with the certificate. "Test outlook connectivity" should tell you more.

DirkMare
0
 

Accepted Solution

by:
Sekodata earned 0 total points
ID: 39710058
I found the culprit. The certificates were ok, but the reason why the users were asked for credentials twice was because the "users" on the exchange publishing rule were set to only "Authenticated users", instead of "All users". Therefore TMG asked for credentials first, before letting them authenticate to the Exchange server.

Thanks anyway!
0
 

Author Closing Comment

by:Sekodata
ID: 39719764
Resolved it myself
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
If something goes wrong with Exchange, your IT resources are in trouble.All Exchange server migration processes are not designed to be identical and though migrating email from on-premises Exchange mailbox to Cloud’s Office 365 is relatively simple…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question