Solaris 10 - Links not up

Hi,

I have a Solaris 10 system and I have a heartbeat network in the interfaces 1 and 2, the cables are connect correctly but the links are not up.

I want them to be with Link UP but NOT plumbed. Is there any command to UP the link? Or it should be automatically when I plugged the ethernet cable?

root@dp-node9 # dladm show-dev
igb0            link: up        speed: 1000  Mbps       duplex: full
igb1            link: unknown   speed: 0     Mbps       duplex: unknown
igb2            link: unknown   speed: 0     Mbps       duplex: unknown
igb3            link: unknown   speed: 0     Mbps       duplex: unknown
usbecm0         link: up        speed: 10    Mbps       duplex: full

root@dp-node9 # ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
igb0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 10.129.68.47 netmask ffffffc0 broadcast 10.129.68.63
        ether 0:10:e0:3e:c3:1c
usbecm0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 4
        inet 169.254.182.77 netmask ffffff00 broadcast 169.254.255.255
        ether 2:21:28:57:47:17
joaotellesAsked:
Who is Participating?
 
Joseph GanConnect With a Mentor System AdminCommented:
Try following command:
# ifconfig interface address netmask subnet address up

eg:
# ifconfig igb1 up
0
 
Pepe2323Commented:
Have you checked if the lights of those network card are blinking ?

if  Solaris reports no link there are only few options

network card is not working
Cabled are bad

Pretty much should be something physical

Regards
0
 
joaotellesAuthor Commented:
tks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.