Solved

Cisco VTY Session Question

Posted on 2013-12-10
5
516 Views
Last Modified: 2013-12-15
Experts,

Can someone please take a look at the following vty line configs and let me know why I can't open more than one vty session?

line vty 0
 exec-timeout 60 0
 login authentication vty_access
 transport input all
line vty 1
 exec-timeout 60 0
 login authentication vty_access
 no exec
 transport preferred none
 transport input all
line vty 2 4
 exec-timeout 60 0
 login authentication vty_access
 transport input all
line vty 5 15
 exec-timeout 60 0
 login authentication vty_access
 no exec
 transport preferred none
 transport input all
!

Cheers

Carlton
0
Comment
Question by:cpatte7372
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 22

Accepted Solution

by:
Matt V earned 250 total points
ID: 39708631
Is there a particular reason you have split the vty config that way?

Normally you would do a line vty 0 15, or a line vty 0 4 and then another for 5 - 15.

Try changing the first vty config to line vty 0 4 and see if that resolves it.

You may be getting stuck in the first config and it only configures one vty.
0
 
LVL 25

Assisted Solution

by:Ken Boone
Ken Boone earned 250 total points
ID: 39708632
Well I don't know BUT here is my guess...

The first session goes to line 0 and connects.

The second session goes to the next line in sequence  which is line 1.  Line 1 is configured for no exec so it fails the session.  Line 1 never gets connected so when you try again it keeps trying line 1.

Just set up line 0-4 to allow the exec session and you should be good.
0
 

Assisted Solution

by:cpatte7372
cpatte7372 earned 0 total points
ID: 39708753
Thanks for responding

I will make the change and see what happens

Cheers

Carlton
0
 
LVL 12

Expert Comment

by:atrevido
ID: 39708929
As an aside here - I'd like to see you secure those VTY sessions better - add the following line to your lines:

line vty 0 4
transport input ssh

ssh should be your routers only communication protocol

crypto key generate rsa modulus 2048
 ip ssh time-out 120
 ip ssh version 2
0
 

Author Closing Comment

by:cpatte7372
ID: 39719728
Both solutions worked.

Cheers
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question