• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 640
  • Last Modified:

Internet Explorer 10 & 11 Hanging!

Getting a lot of hanging by IE 10 & 11 on various websites. Not a crash! Just a 10-15 second hang!

What are the most probable fixes?

Tks
0
mtnhome
Asked:
mtnhome
  • 3
  • 2
  • 2
  • +3
5 Solutions
 
TunerMLSystems EngineerCommented:
That's usually because of page rendering issues, is installing a third party browser such as firefox out of the question?
0
 
comfortjeaniusCommented:
Could be an add-on issue did you try to open Internet explorer in safemode?

Windows key + r
Type: iexplore -extoff and hit Enter

Now see if you getting the same hanging issue

You can try and revert back to Internet Explorer 9
0
 
Craig KehlerDirector of Customer Service & Community RelationsCommented:
The most probably fix is install Chrome. :) But if you insist on using IE...

Do the sites have anything in common? Flash player? Ones you visit commonly?
Have you cleared out your browser history? (Note that you will lose saved logins if you clear out everything)
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
jcimarronCommented:
mtnhome--I notice that getting to any site involving Google is quite a bit slower starting this week.
0
 
GeisrudSystems AdministratorCommented:
Also consider trying those pages in compatibility mode.
0
 
mtnhomeAuthor Commented:
Maybe I should just move to Chrome or Firefox?

Always wondered why IE is the only browser with a Compatibility Mode!
0
 
GeisrudSystems AdministratorCommented:
I'm sure just about everyone on E-E would recommend some browser other than IE.  I can say that some sites used in my organization just do not work on versions 10 or 11 - thus we don't use those versions.  In some cases, we have to direct users to use compatibility mode to get the site to work.
0
 
mtnhomeAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 167 points for Geisrud's comment #a39709585
Assisted answer: 166 points for TunerML's comment #a39709044
Assisted answer: 167 points for scrutinizer's comment #a39709129
Assisted answer: 0 points for mtnhome's comment #a39709544

for the following reason:

Decided to take the advice of many and drop IE in favor of Chrome. Took me awhile to set up everything, tool bar primarily, but all is well. No hanging!

Tks
0
 
mtnhomeAuthor Commented:
Fixed the issue!
0
 
jcimarronCommented:
mtnhome--Glad all is well.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now