Solved

NAT in cisco Router

Posted on 2013-12-10
4
465 Views
Last Modified: 2013-12-25
Hi,


I need a help for NAT in cisco router

here is the scenario

                              PC1
                               |
            Remote   Router1 ------Router 2
                               |                   |
                           radio link         satellite link
                               |                   |

               Base    Router 3-----Router 4
                                |
                              PC2
                               
Brief about topology :


1.Customer having two locations named Base and Remote

2. Base side and Remote side each consisting 2 routers

3. Among 2 routers , each of them connected via radios and other router connected with Satellite. ( pls refer topology diagram)

4.PC1 IP address : 192.168.11.5
   PC2 Ip address : 10.0.0.3

5. R1 an R3  connected via radio link
    R2 and T4 connected via satellite link

6. R1 and R2 connected through ethernet
    R3 and R4 connected through ethernet

7.  PC1 connected to R1 router interface
     PC2 connected to R3 router interface





My requirement :

How to configure  Router R1 to NAT as below

1. IP 192.168.11.5 has to  NAT  192.168.17.1 using source port and destination 80 and 80 and should pass through Radio link

2. IP 192.168.11.5 is has to  NAT  192.168.18.1 using source port and destination 3389 and 3389 and should pass through satellite link

How to configure  Router R3 to NAT as below

3. Ip address 10.0.0.3 need to  NAT  225.0.0.3 using source port and destination 80 and 80 and should pass through Radio link

4. Ip address 10.0.0.3 need to  NAT  225.0.0.3 using source port and destination 3389 and3389  and should pass through satellite link
   
Actual requirement :

1. When i access 225.0.0.3 with port 80 from PC1 , it should go via radio link
    when i access  192.168.17.1 with port 80 from PC2 , it should go via radio link

2. when i access 225.0.0.3 with port 3389 from PC1 , it should go via satellite link
    when i access 192.168.18.1 with port 2289 from PC2,it should go via satellite link

Pls help with the configuration of the above requirements of NAT and traffic flow

Thanks
Ramu
0
Comment
Question by:RAMU CH
  • 2
4 Comments
 
LVL 6

Expert Comment

by:sharjeel ashraf
ID: 39709490
please post sanitized config for the routers.
0
 
LVL 1

Author Comment

by:RAMU CH
ID: 39710424
Hi,

Will you pls share how to configure for the above requirements in cisco router...

I don't have sanitized configuration and i am trying for my customer using GNS3

Regards
Ram
0
 
LVL 2

Accepted Solution

by:
SpencerScannell earned 500 total points
ID: 39711573
You could probably use a route map. Not sure if it'll work, but it's worth a try in GNS3. A sample config might for the BASE site might be:

access-list 1 permit 192.168.11.5
!
ip nat inside source list 1 interface Serial 0/0/0 (¿THIS IS THE INTERFACE POINT TO THE WAN) overload
!
access-list 150 permit tcp host 192.168.11.5 any eq 80
access-list 151 permit tcp host 192.168.11.5 any eq 3389
!
route-map TEST permit 10
 match ip address 150
 set interface Serial 0/0/0 ¿ INTERFACE FOR RADIO LINK
route-map TEST permit 20
 match ip address 151
 set interface Serial 0/0/1 ¿ INTERFACE FOR SATELLITE LINK
route-map TEST permit 30
(DON'T USE ANY MATCH OR SET STATEMENTS ON THIS LINE)
!
interface fa0/0 ¿ INTERFACE CONNECTED TO THE PC
ip policy route-map TEST



Then you could check to see if it's working properly by using the command show route-map. It will show you if there are any matches where it says policy routing matches.
Good luck!
0
 
LVL 1

Author Closing Comment

by:RAMU CH
ID: 39739005
Tks
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now