Solved

Stand alone viewer for DTS packages

Posted on 2013-12-10
7
1,191 Views
Last Modified: 2013-12-23
I have SQL Server 2008 and 2012 on my box at work.  We're trying to upgrade one of our SQL Server 2000 suite of databases to 2012.  I have been asked to document various DTS packages.  I do not need to change them, just look at them.  I'm running Windows 7 and there is a SQL Server 205 DTS designer from Microsoft, along with a backward compatibility iinstall which if I understand things correctly, will allow me to look at DTS packages in SQL Server 2008 Studio Manager.  But the backward compatibility won't install on Windows 7.  My question is this.  Is there a stand alone DTS viewer?  As I don't need to execute or modify them, I just want to see them.  DBAs have exported DTS packages to DTS files with the .dts extension so I want to open up those files and have a look.  I don't have access to msdb so it looks like I am stuck with the .dts files.
Thanks.
0
Comment
Question by:lizmarc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 25

Expert Comment

by:jogos
ID: 39710565
0
 

Author Comment

by:lizmarc
ID: 39710738
Yes.  I don't have access to the DTS packages in the database proper.  My only avenue to viewing the packages is through the exported dts files as I don't need to edit them.  If I try to open the dts file (file | open) I get the message that there is no editor installed.  Would the solution you pointed to fix this?  It seems geared toward the object explorer in management studio.  Thanks.
0
 
LVL 25

Expert Comment

by:jogos
ID: 39711992
It is a response on 'won t install on w7'
0
Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

 

Author Comment

by:lizmarc
ID: 39712632
Actually I should have said it is probably the fact that I'm running 64 bit Windows 7.  I seem to remember SQL Server 2008 setup features having some 32 bit stuff involved but I think it is a 64 bit issue not a Windows 7 issue.
0
 
LVL 75

Accepted Solution

by:
Anthony Perkins earned 500 total points
ID: 39718206
There is no problem viewing (and running) DTS packages that are stored in msdb on SQL Server 2008 (or SQL Server 2008 R2 for that matter), regardless of whether you are using Windows 7 32-bit or 64-bit.
0
 

Author Closing Comment

by:lizmarc
ID: 39735834
I eventually solved the problem.  It had to do with making sure the path settings were right and copying the RLL files into a directory that did not exist but which Management Studio 2008 was looking for.  Once I created the desired foler and put the RLL files there it worked.
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 39737244
Yep.  That is correct.  

And thanks for the outstanding grade, I am definitely going to keep your name in mind, next time you post a question.
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

JSON is being used more and more, besides XML, and you surely wanted to parse the data out into SQL instead of doing it in some Javascript. The below function in SQL Server can do the job for you, returning a quick table with the parsed data.
A Stored Procedure in Microsoft SQL Server is a powerful feature that it can be used to execute the Data Manipulation Language (DML) or Data Definition Language (DDL). Depending on business requirements, a single Stored Procedure can return differe…
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.
Using examples as well as descriptions, and references to Books Online, show the different Recovery Models available in SQL Server and explain, as well as show how full, differential and transaction log backups are performed

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question