Windows 8.1 folder permission issues

Hi guys,

This is a follow-up question from ticket ID28300026, but unrelated enough that I felt it was suitable to create a new post.

This same Windows 8.1 machine was having troubles, so replaced the HDD and started from scratch, installing and setting up Windows 8, then upgrading to Windows 8.1 via the Windows Store.

All user data was transferred successfully to the machine from a reasonably current backup. However, originally when trying to open a document, it would only show in read-only mode. A quick permissions adjustment saw that issue resolved, however we don't seem to be able to save documents anymore (we're told we don't have the permission. Interestingly, data can be saved onto external USB devices without issue and, even more interesting, we can create a folder, move files (and sub-folders!) in the folder we can't save to into the newly created folder and can then open, save and do whatever we please without incident.

It sounds like a permissions/ ownership issue to me, but I thought I'd done it correctly (unless what I've done previously through Windows 7 isn't as effective here.

Would love to know the best course of action because I know there's a better way to resolve this that to create a whole bunch of new folders and transfer everything to those!
Servant-LeggieAsked:
Who is Participating?
 
Dan CraciunConnect With a Mentor IT ConsultantCommented:
That's :F. It means "full rights".

Here's how to give full rights to the administrators group on your folder:

ICACLS C:\Users\Tom\Documents /grant administrators:F /t

In english this means: (/)grant (:F) full rights to administrators to (/t) all the files and folders in C:\Users\Tom\Documents

http://technet.microsoft.com/en-us/library/cc753525.aspx
0
 
Dan CraciunConnect With a Mentor IT ConsultantCommented:
Take ownership to that folder using, in an elevated command prompt:

TAKEOWN /f X:/path/to/files /r /d y

Then grant permissions to the user/group:
ICACLS X:/path/to/files /grant <user/group>:F /t

HTH,
Dan
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
I would create a new profile, rename the old one and take ownership of the folders before copying them to the new profile.

If all works well, then delete the renamed profile.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
Servant-LeggieAuthor Commented:
DanCraciun, can you please confirm the second line you suggested? I completed TAKEOWN /f <X:/path/to/files> /r /d y successfully, but the second line didn't seem to produce results. Specifically, I wasn't sure what "F:" was doing at the end of the string, so didn't know how to proceed. Perhaps you can give me an example of this line... let's say the files/ folders are at C:/Users/Tom/Documents and, for the user/group info, that he's 'Tom'.
0
 
Servant-LeggieAuthor Commented:
Thanks, Dan Craciun. That will do the trick - you've been an awesome help!
0
 
Dan CraciunIT ConsultantCommented:
Glad I could help :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.