Solved

Problem installing Citrix Web Interface with Secure Gateway

Posted on 2013-12-11
3
1,062 Views
Last Modified: 2013-12-12
Hi Experts,

I am installing Citrix Web Interface 5.4 with Secure Gateway 3.3 on Windows 2008 R2. I have already installed SSL certificate on the server. I have already installed WI and then Secure Gateway. I connected Citrix Farms on the server. Everything gone fine. I configured https on default web site on IIS at port 444. My secure gateway is configured to port 443.

Now if I open the link, with local host (https://localhost:444/Citrix/XenApp/auth/login.aspx) its opening however its not opening when I do it using proper url(https://ctxgw.com/Citrix/XenApp/auth/login.aspx). its says bad gateway.
Bad Gateway
What should I do?

By the way, I have created two DNS entry on DNS server. one of ip to server name and one for ip to ctxgw.com.
SecureGateway-Report.txt
0
Comment
Question by:bubaibhatta
  • 2
3 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39710974
Several notes:

1. .Com is one of the high level domains on the root domain in public and shouldn't be used for private networks.

2. You DNS should have an A record to map the name into IP

3. Ensure that the private key of the certificate is installed on your server

If I were you, I wouldn't enable 443 on the WI IIS default website.
0
 

Author Comment

by:bubaibhatta
ID: 39711572
Hi Mutawadi,

1. This installation is going to be a production server and this domain is a registered one.

2. I already created DNS record for the same.

3. I have installed both Intermediate and SSL certificate. However how do I ensure the private key of the Certificate is installed on my server?

4.  You said, you would not enable 443 on the WI IIS default website. Here is what I did:

IIS
WI
Secure Gateway

Please help and guide me to resolve the case.......
0
 
LVL 23

Accepted Solution

by:
Ayman Bakr earned 500 total points
ID: 39712331
Sorry for the typo; I meant you have enabled SSL 444 on the WI default website - why are you doing this if you are already going to connect to your XA resources through a CSG which is on port 443.

I would keep the default website on 80, and the CSG then would be on 443.

For installing the private key follow this:

https://www.geocerts.com/csr/citrix_secure_gateway_windows
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
LPT Port to USB Printer Windows 7 23 644
Currupt user profile issue. 4 73
Hibernate on windows 10 18 118
Permanently disable Server 2012 hiberfil.sys file 3 92
Citrix XenDesktop, gold image, VMware, vSphere.
Several part series to implement Internet Explorer 11 Enterprise Mode
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now