Solved

Problem installing Citrix Web Interface with Secure Gateway

Posted on 2013-12-11
3
1,085 Views
Last Modified: 2013-12-12
Hi Experts,

I am installing Citrix Web Interface 5.4 with Secure Gateway 3.3 on Windows 2008 R2. I have already installed SSL certificate on the server. I have already installed WI and then Secure Gateway. I connected Citrix Farms on the server. Everything gone fine. I configured https on default web site on IIS at port 444. My secure gateway is configured to port 443.

Now if I open the link, with local host (https://localhost:444/Citrix/XenApp/auth/login.aspx) its opening however its not opening when I do it using proper url(https://ctxgw.com/Citrix/XenApp/auth/login.aspx). its says bad gateway.
Bad Gateway
What should I do?

By the way, I have created two DNS entry on DNS server. one of ip to server name and one for ip to ctxgw.com.
SecureGateway-Report.txt
0
Comment
Question by:bubaibhatta
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 39710974
Several notes:

1. .Com is one of the high level domains on the root domain in public and shouldn't be used for private networks.

2. You DNS should have an A record to map the name into IP

3. Ensure that the private key of the certificate is installed on your server

If I were you, I wouldn't enable 443 on the WI IIS default website.
0
 

Author Comment

by:bubaibhatta
ID: 39711572
Hi Mutawadi,

1. This installation is going to be a production server and this domain is a registered one.

2. I already created DNS record for the same.

3. I have installed both Intermediate and SSL certificate. However how do I ensure the private key of the Certificate is installed on my server?

4.  You said, you would not enable 443 on the WI IIS default website. Here is what I did:

IIS
WI
Secure Gateway

Please help and guide me to resolve the case.......
0
 
LVL 23

Accepted Solution

by:
Ayman Bakr earned 500 total points
ID: 39712331
Sorry for the typo; I meant you have enabled SSL 444 on the WI default website - why are you doing this if you are already going to connect to your XA resources through a CSG which is on port 443.

I would keep the default website on 80, and the CSG then would be on 443.

For installing the private key follow this:

https://www.geocerts.com/csr/citrix_secure_gateway_windows
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question